Diablo® III

Still cant even install, let alone log in

I am still getting the "Unable to Initialize Streaming" error. I tried about 50 times before I went to sleep and assumed it would work this morning after servers launched, but I still can not install the game.

I tried installing WoW just to see if it was an issue on my end, but that was working fine. I am wondering how many people are stuck at this phase still and if there is a real solution aside from deleting agent file / enabling firewall ports... It is very sad that I can't even install the game.
Reply Quote
same here
Reply Quote
100 Blood Elf Rogue
7300
Posts: 32
Same, Launch day and still can't install.
Reply Quote
Same here, and its a day after launch..... brother already playing.. kinda making me mad
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]