Diablo® III

Launcher not starting the game

Posts: 40
The launcher gets stuck after I hit play.
I've been traying for half an hour.

Please help.
Reply Quote
Posts: 40
It gets stuck either on "Updating Tools (0%)" or after I hit play.
Reply Quote
85 Blood Elf Priest
5980
Posts: 10
I have a similar problem - I've uninstalled and re-downloaded, and the launcher comes up with no problems, but when I hit play, the launcher disappears like it's launching the game and I get nothing.
Reply Quote
I have the same issue and just tried what you've suggested, it did not work for me. I found the .exe file, tried to launch, same issue.
Reply Quote
90 Tauren Paladin
1405
Posts: 1
same issue now hit play and it brings up Diablo 3 loading icon but game never starts.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]