Diablo® III

the folder "xxxxxx" cannot be created

(Locked)

hi everyone, i spent hours trying to install d3. first i had the problem of "updating setup files" which is stuck at 33%. and i found the fixes by digging so much in the internets i couldve reached hell and back.
you can find the list here.
http://www.keenandgraev.com/2012/05/12/diablo-3-stuck-updating-setup-files-fix/
#5 worked for me, where i downloaded a copy of the setup files and extracted the zip file on
"C:\ProgramData\"
which should contain "C:\ProgramData\Battle.net"
the folder should have 3 folders inside:
Agent, Client, Setup. (where Client is the one that got stuck during the Agent launcher).

If you can't find the folder above, then it's because ProgramData is hidden. please just do yourself a favor and search for how to "Show hidden folders in <OS>".

After i got through this, i encountered the error when Diablo III installation started. it only went up to 0% and prompted this:
"C:\Program Files (x86)\DiabloIII.temp". (ConflictManager:CreateObjects)

And this might mean that the user doesnt have permission to write in the program files folder. which got me puzzled since im an Administrator, and i just installed my OS.
And it's Windows 7 Ultimate 64 bit

I had no choice but to reinstall my OS again! using Windows 7 Ultimate (the 32 bit Version!)
and i crossed my fingers and spent hours again without sleep to wait for installation.. blah blah..

And then finally, i did Diablo 3 installation again from the start (same error as the initial part) and then got to the launcher part, where it went from 1% to 69% (and i again encountered another "stuck in oblivion" where the percentage wasnt moving)..
turns out, it was just the Internet Options.

go to your internet explorer > (Menu) Tools > Internet Options > Connections (tab) >
click LAN Settings (below) > uncheck "Automatically Detect Settings" > OK.

you can do the last set of steps above even during 69% or 77%. and then you will see that in a few minutes it will continue downloading.

And after 10 hours of installation.. hope you share this info if it helps you.
Thanks,!
OMG... having the same problem. Just bought the game and cant even play it. Keep getting the same error.
I thought I fixed it by running it in Windows XP comp/Admin mode but it got to about 8% install and through up another creating folder error.

Very frustrating!!!
** Update... finally installing... try running as Admin in Windows XP mode... worked for me, :)

I am sitting at 10% install with 8.18GB left to download
The "WinXP Mode" also worked for me...

THX!

[necro'd thread]
Edited by Omrakos on 1/16/2013 4:59 PM PST
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]