Diablo® III

changed language

So, while being bored, because of the downtime on the Americas server, I decided I would change the language from English to Korean. It told me I would need to restart the game client.

Now I am stuck on a 2.5 GB download...any way to bail on this?
Reply Quote
90 Human Death Knight
3775
Same thing happened to me, getting me really annoyed... Just wait so it is a available and click play. Then click on option and change it back to english.
Reply Quote
same boat here too... sigh, is there really no way to cancel this and go back to english?
Reply Quote
85 Human Priest
3025
Wow old thread and no solution. I had this happen because I was in widescreen 5076 x 1080 but turned off eyefinity. The screen was so squashed I couldn't really see and fumbled through the menu thinking I was changing resolution but alas it must have been language. FML
Reply Quote
I'm had this happen to me just now and I'm on a slow connection.. seems like Blizzard is pissing EVERYBODY off wiht this language BS business.. BAD MOVE BLIZZARD!
Anyhow.. so how the hell do I revert this? Must I endure 1 day download just cuz I changed a setting?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]