Diablo® III

Pixelated lighting

(Locked)

90 Blood Elf Paladin
0
Not sure if this is an old thread or if its been fixed already, but I am playing diablo 3 and fire/lighting and even some of the shading/lighting effects on objects seems to be creating errors to the point to where i just get big pixels on my screen and it distorts the image, it always does this when i select a npc or my banner or myself in the character screen.

Running Radeon HD 3870 i beleive, my CCC says 3800 series tho, if i need to post any other info please let me know ill be more than happy.
90 Blood Elf Paladin
0
Edit: now that im playing, some of my wizards spells are invisible as well.
Same problem, same card. Tried the 12.4a Catalyst hotfix drivers. No go. Heard from some people that un-installing your drivers and going back to 10.1 fixes this issue. Going to test, and will edit post with results.

EDIT: This worked. Uninstalled Catalyst Drivers as follows:

Control Panel -> Programs and Features -> Selected AMD Catalyst Control Center, right clicked, hit 'Change'. Told it to perform "Express Uninstall" the bottom most option of the three. Went and got 10.1 Catalyst (x64) from Guru3D at this time. Finished uninstall, rebooted. Installed Catalyst 10.1, rebooted. Started D3, no light artifacting.

Hope this helps, and happy hunting!
Edited by Lazarus#1858 on 5/15/2012 2:39 AM PDT
90 Blood Elf Paladin
0
Edit: Awesome, im doing it now ill let ya know how it goes

Editedagainz: AWESOME its fixed YATTA, ty
!
Edited by Salvenos#1119 on 5/15/2012 3:23 AM PDT
I am having the same problem with the same card, will try the fix. Thanks!

Update: Downloaded 10.3 and working great now. Annoying message when starting up game that says video card is out-of-date.
Edited by Maya#1110 on 5/15/2012 8:20 AM PDT
Same card, same issue. I will suck it up until ATI puts out drivers...yay.
90 Undead Warrior
9270
Ditto to all. Pixelated lighting. Same card (desktop HD 3870). NOT the horrible graphical errors they made ccc 12.4a for.

I may just do as Paladwyn and hope for further updated drivers.
I had the exact same problem with the exact same video card. I did as Lazarus suggested and now everything works well. Thanks a million for the fix.

+10000
85 Tauren Hunter
1730
wont let me open with open office says i have to use winzip?
Don't forget, the problem with dropping back to 10.1, could mean that it has the possibility (and in my case....a certainty) of breaking other games. Just be careful with dropping down, the next time you run a different game it may cough and sputter.
So, any idea when ATI might put out the drivers to fix this issue?
I'm with you Paladwyn, I don't want to drop down.
83 Undead Warlock
4100
Same issue with lighting, running a 3750hd laptop, rolling back to 10.3 drivers didn't fix, attempting to roll back to 10.1 =(

It doesn't like rendering water, and certain monsters with lighting effects become practically invisible except for the life bar.
I'm having similar issues with a HD 3650 in my lap top. However, reverting to 10.1 still causes pixelation around light sources etc. Things like my hands for TP casts etc, lanterns weapon glows and such.
I also read that dropping to 9.3 (I think) also worked...but to what extent?

I'm still suffering, and I know Blizzard is aware of the issue, so it should just be a matter of time. I sincerely hope they will decide to give a crap about the customers that are affected by this, as it falls in the realm of supported cards.

Come on Blizzard/ATI, lets get this fixed.
85 Blood Elf Priest
2645
I've had the exact same problem, basically same cards (ATI Mobility Radeon HD3870x2). I rolled back to 10.1 and it works great (even majorly boosted my fps in wow), except only one of my cards is working now. The other is getting the "this device cannot start (code 10)" error. This happens every time I try to install a driver from anyplace other than ATI's auto-detect driver thing on their website. Any idea how I can get it to work for both cards? Thanks in advance!
Same problem here. i'm x2 as well. I don't want to roll back drivers as it is helping reduce errors with other programs.
hy to all !!
i was having the pixelation problem whit diablo 3 using the video card ati radeon hd 2900 pro
after many instalation of driver 12.4 , 12.4a hot fix , 12.4b hotfix , 12.6 beta all drivers instal not fix the pixelation problem !!! i uninstal the driver and the video card driver and fresh instal the 12.3 driver and fix the problem
now diablo run very nice and the pixel look ok
I'm gonna unbury this thread, 'coz I'm having the same problem, but I'm using a Nvidia GPU (GTX 660 Ti), and I can't seem to find a solution.

Also, once it happens, any image I load ends up with some pixelated parts, and I have to reboot or suspend the PC to fix it...
Support Forum Agent
vinipc,

Please don't "unbury" threads, it's called necro'ing and we typically lock threads when it's done as I'm going to have to do to this one.

Just make a new thread of your own and in it provide a full description of the problem as you see it along with a list f steps you've tried so far in resolving it. Your dxdiag will also be useful in this case.

You can find this information in the Direct X Diagnostic Tool:

Click on Start
Click on Run
Type in: dxdiag (In Vista, type dxdiag in the search field)
Hit Enter or OK

Click on the Save All Information button at the bottom, and create a dxdiag text file, and copy and paste it ALL here.

Could you also post your D3Prefs.txt file? It's located in the My Documents\Diablo III folder.
This topic is locked.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]