Diablo® III

Can some one please help me with my issue?

85 Gnome Rogue
2190
Posts: 26
I left the installer "installing" for the last 5 hours and I've restarted it numerous times and it's STILL stuck at 0%........before i install is it says that i need better system requirements to run it, is that why? Please help, I'm eager to play this game just like many of you and i still can't even get past the installer boss....
Reply Quote
Posts: 118
05/15/2012 06:06 AMPosted by Kurinaxx
I left the installer "installing" for the last 5 hours and I've restarted it numerous times and it's STILL stuck at 0%........before i install is it says that i need better system requirements to run it, is that why? Please help, I'm eager to play this game just like many of you and i still can't even get past the installer boss....


Pretty sure that's why. I had the same problem on my crappy work pc.
Said "you do not meet minimum system requirements" and just sat there at 0% on a connection with easily 25mbps download speeds.
Edited by Abomination#1395 on 5/15/2012 6:09 AM PDT
Reply Quote
85 Gnome Rogue
2190
Posts: 26
Don't understand why that would disable you from being able to download the game..not to mention when i was playing the beta the game was running exceptionally well.
Reply Quote
100 Blood Elf Death Knight
11305
Posts: 13
Is there any kind of solution waffles?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]