Diablo® III

Launcher trying to download patch every time

Every time I try to play, the launcher tries to patch the game again... It stays at "Initializing" for about 3 minutes, then it jumps to 100%....
Reply Quote
same here bro
Reply Quote
Ive already installed the game and have played it and now its asking me like i just got the game again and i need to install??? Ive already installed. Payed. Played.
Reply Quote
90 Gnome Rogue
3650
Posts: 3
I'm having the same problem. I've played once, got off, tried to play again, but it says either "Exit" "Install" or "Manual" and it doesn't say "Play" anywhere...
Reply Quote
Mine is doing the updating thing every time as well but I can't even play the thing. After working for about 5 hours at getting past the "setup files updating" freeze I run into this.

I am so dissapointed in you blizzard you have let so many people down you are not the developer you once were. I mean really you released something and called it a game when in fact it is just more like beta Mk2
Reply Quote
Someone needs to start a global gamers union.
Reply Quote
iv already installed the game played it twice and now it asks me to install again also with manual or exit the other options so annoying
Reply Quote
I already installed and fixed all the issues in configuring diablo III weeks before and updated the patch already completely and played with it for weeks.

Yesterday May 25, 2012 (Philippine time) I received new updates and waited for it to finish. that's cool because it suppose to fix known issues in the game. But when i tried opening it today it's still downloading new patches? Ok fine, maybe the dev's have been busy deploying new consecutive patches in two days. After finishing the patch download for 10minutes, I closed the game expecting that it should start right away next time i open it. So... I opened it again.
"Surprise!!!!" IT'S FREAK'N PATCHING THE GAME AGAIN!!!!!!!

What is going on BLIZZARD!!!!!!

Why is it patching again every time i open it (Diablo III) even if I've already downloaded the patch completely just minutes ago?

Don't tell me that i need more patch to patch this game patching?
Reply Quote
MVP - Technical Support
Posts: 10,015
View profile
for some reason it didn't complete, did you hit play at all before letting it finish? the update is just a launcher update only, not a game client update.

how do you know it's finished when you quit? does it say "game is up to date" or what does it say? cause it sound slike it's just being quit too soon and starting over every time. ALso before opening again you need to wait at least 30 seconds or "agent" will still be running and then it definitely won't work right when you reopen it too fast.
Reply Quote
Posts: 1
I'm having the same issue. Every single time I launh Diablo 3, the "Updating Blizzard Launcher" percentage count starts. It takes at least 5 minutes, every single time. This happens after I just reboot, it happens when I haven't played in hours, it happens every single time I launch. How can we make this stop?
Please, Blizzard, PLEASE give us a patch that will allow us to play our single-player games that we paid for and own. You did it with SC2, so that you can play your games off-line. I can't think of how many times I've been wanting to play D3 and haven't been able to because YOUR computers are busy. Most of us don't care about your servers. All we want is to be able to play our game. Please give us a patch that will let us do so.
Reply Quote
Support Forum Agent
Posts: 14,784
I'll be happy to pass that feedback up.

As for the patching issues, have we've tried the basics and see if this helps?

Repair Permissions via Disk Utility
    1. Navigate to /Applications/Utilities/ and open Disk Utility.
    2. Select the hard drive the game is installed on.
    3. Select the First Aid option.
    4. Click on the Repair Disk Permissions button.

Resetting permissions on the Diablo III folder
    1. Select the Diablo III folder
    2. Press Command + I
    3. In the Info box, go to the Sharing & Permissions section and click on the lock and unlock it, entering your admin password when prompted.
    4. Make sure you have Read & Write permissions
    5. Click on the Burst icon (cog wheel) and select Apply to enclosed items
Reply Quote
That doesn't work..the problem is clearly with the patch, as loads of people have this issue with MAc and PC..this is a complete JOKE!
Reply Quote
Machkhan, that doesn't work.
Reply Quote
MVP - Technical Support
100 Draenei Mage
6810
Posts: 18,768
Try this guys :

http://us.battle.net/d3/en/forum/topic/5592449294#3

(not my fix but seems to help for the looping thing)
Reply Quote
@Bluespacecow

Doesn't work for me. My agent.db already pointed to the enUS address. It seems to be a problem on the Blizzard server, rather than on any one person's client.

And Machkhan, your suggestions don't work.
Reply Quote
MVP - Technical Support
100 Draenei Mage
6810
Posts: 18,768
@BassMatic

If you're on can you zip up your logs and email them to me at bluespacecow@gmail.com

I'll need the ones in ErrorReporter and Logs of the Diablo 3 folder as well as the ones in the Battle.net folder.

Just make a copy of the battle.net folder and delete the app programs inside preserving everything else.

Also include a copy of .agent.db in the D3 folder which will be hidden.
Reply Quote
@Bluespacecow

My system isn't crashing, and unlike other users the game has always been playable-ish (though lag varied from 250-500+ ms). My problem is simply the restart loop every time I log into any server but the Americas. I'll send the D3Debug.txt, agenet.db and blizzard updater log.html, but I'm not sure I follow you on the battle.net folder. It's got a whole bunch of directories with some sub directories that are 1 letter/1 number combinations. Do you want all of those? There's not a whole lot...
Reply Quote
When will the EU servers be patched?

I think it's really ackward maintenance is over 24 hours async, also I can't temporarily convert my characters to an other server without a hassle, while my license says it's global
Reply Quote
ARGH, everytime I try to play diablo, screen comes up for Diablo 3 V.1.0.6.13300 everytime, and i have to wait 3 minutes before it starts to even download, then it goes to 100%.
I have uninstalled Diablo 3 completely and reinstalled it and I still got the same problem -_-'
Reply Quote
yes every patch time we have many problems with joining the game and frame rates. It is stable for a while and with the new patch everything same happening again.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]