Diablo® III

Diablo 3 Black Screen When Clicking Play

I got to the point of being in application support/blizzard/diablo3 but the folder is empty. Any idea where else it could be? I did a digital download if that matters
Reply Quote
I got D3 to work on my macbook with the unsupported graphics card but.... i dont recommend you even bothering to find your way around it. the game loads and everything but the gameplay is literally like at 1-2 FPS, completely annoying i just uninstalled.
Reply Quote
05/16/2012 03:59 PMPosted by TheRealCP3
I got to the point of being in application support/blizzard/diablo3 but the folder is empty. Any idea where else it could be? I did a digital download if that matters


same thing happened to me, I also did a digital download.
Reply Quote
85 Dwarf Shaman
1300
Right click on finder and select "go to folder..." when the text box appears type in "~/Library"

that should take you to where you need to go for the application support folder.
Reply Quote
If I reset my preferences, I can play, but I have to do this every single time I start the game.
Reply Quote
I don't think you need Onyx. From the finder, just hold down the option key and click on "Go", then click on Library and you can find the Application Support folder in there.
Reply Quote
the same thing was happening to me but if you go to options and reset the game preferences before every time you play if will work.
Reply Quote
I found a way, If you change your screen mode, like the full screen , or open on a window it works form me without doing anything like, changing the preferences.
Reply Quote
Hey Guys,

When I try to load diablo 3 on my mac I get a black screen and just a mouse shows nothing happens.

I've been trying to figure this out but all the threads from here aren't available.

What can I do to play?

I have a mac with a GMA X3100 graphics card thats unsupported but can i still somehow play?

This is why you are getting the blackscreen. This chipset is not supported for D3.
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment | Sun-Thur

This is small step for me, but big step for humanity. Or something like that...


I found a way, If you change your screen mode, to the full screen window from just full screen It works fine now. I also tried with window, it also works. I dont get the black screen anymore. Hope it helps.
Reply Quote
It worked to me but now i have 3007 error
Reply Quote
My game freezes / black screen after I use Frost Nova on my wizzard. How do I fix this?
Reply Quote
85 Worgen Priest
5345
I have the same issue, but i cant seem to find the d3prefs.txt file... so I have no idea what to do.
Reply Quote

This is why you are getting the blackscreen. This chipset is not supported for D3.
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment | Sun-Thur

This is small step for me, but big step for humanity. Or something like that...


I found a way, If you change your screen mode, to the full screen window from just full screen It works fine now. I also tried with window, it also works. I dont get the black screen anymore. Hope it helps.


what do u mean by "it works" ?

because its actually working, but it is sooooo slow, its not even playable with the GMA X3100 graphics card ...
Reply Quote
i dont know if this will help anyone but i just updated all my drivers and managed to get exactly this symptom : ie after you hit play, all you see is the mouse cursor and hear music in the background. WTF... updates are supposed to make things work betterest!

to fix it i went to device manager and rolled back my device driver for the NVS4200M in my laptop to 8.17.12.6696. (it was already in my rollback list thank PowerSupply{FSM getting too much attention} as i dont want to even think how i could have got a copy of that driver version for my card at that level from nvidia or anyone else without trawling some dodgy sites...). still cant believe it works to be honest... this 'roll-back' has never, in my 20 years of IT experience EVER worked... but today the game is working so now i leave my beer at the Alter of Device Mangler.

Probably pretty specific and some other workaround is out there but this is what made my stuff work - Lenovo T420S if it helps.
Reply Quote
90 Draenei Shaman
15000
I'm having this same issue, and it's brand new for me. My system IS supported by Diablo.

What happens is that I when I go to open Diablo, the entire screen is black, I can hear the music, and I can see the cursor. When I drag a window over it, or change the size of the window, the graphics appear. But not until I do that. Until I change the size, even if I've drug some window all over it, I cannot type in the account name or password boxes.

Any word on why this is happening now? It's pretty irritating. It's also started happening with the WoW Mists Beta.

Speaking of both of those, is there a good reason that to get to both programs I have to go through TWO other programs before they open? I quite think that one launcher is enough, without having to go through a Blizzard Launcher that's nothing more than a background app before I can even get the WoW/Diablo launcher to open. This is a behavior that I sincerely hope is eliminated.

I'm running Mac OS X 10.6.8.

Hardware Overview:

Model Name: iMac
Model Identifier: iMac7,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.4 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 4 MB
Memory: 4 GB
Bus Speed: 800 MHz
Boot ROM Version: IM71.007A.B03
SMC Version (system): 1.20f4
Serial Number (system):
Hardware UUID: 00000000-0000-1000-8000-001EC204174F

ATI Radeon HD 2600 Pro:

Chipset Model: ATI,RadeonHD2600
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 256 MB
Vendor: ATI (0x1002)
Device ID: 0x9583
Revision ID: 0x0000
ROM Revision: 113-B2250F-219
EFI Driver Version: 01.00.219
Displays:
iMac:
Resolution: 1680 x 1050
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Display Connector:
Status: No Display Connected
Edited by Ryegeleye#1893 on 6/26/2012 9:21 AM PDT
Reply Quote
Support Forum Agent
Try a 10.6.8 combo update to reinstall your drivers for your graphics card.

http://support.apple.com/kb/DL1399
Edited by Machkhan on 6/26/2012 10:32 AM PDT
Reply Quote
90 Draenei Shaman
15000
Try a 10.6.8 combo update to reinstall your drivers for your graphics card.

http://support.apple.com/kb/DL1399


I reinstalled the combo update, and it did not fix the issue. Diablo is also taking a very LONG time to open compared to pre-patch (the one before today). That is with almost no other programs open (a single safari window) and 4 gigs of ram.
Edited by Ryegeleye#1893 on 6/26/2012 2:49 PM PDT
Reply Quote
Support Forum Agent
If it's taking a while to load, then it might be having permissions issues. I mainly like to do Repair Disk Permissions and Repair Disk, as this is health maintenance for your Mac. I would also repair D3 folder permissions.

Resetting permissions on the Diablo III folder
    1. Select the Diablo III folder
    2. Press Command + I
    3. In the Info box, go to the Sharing & Permissions section and click on the lock and unlock it, entering your admin password when prompted.
    4. Make sure you have Read & Write permissions
    5. Click on the Burst icon (cog wheel) and select Apply to enclosed items
Reply Quote
90 Draenei Shaman
15000
I repaired the permissions, it seems to be opening faster than before. But I do not understand what changed to make it black screen like this on start up. Should I try editing anything in the D3prefs file?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]