Diablo® III

Should have delayed launch.....

87 Night Elf Hunter
1480
Finally got it installed (Had to switch to a 4th PC). So I copied files over to my main PC. Now launcher will not update. (But it will update on my crappy machine :/)

Seriously, Blizz should have delayed the launch until they had all this crap fixed.

D3 works on my crappy machine, like it will update but it wont be able to run (its pretty bad lol). But when I copy over the files to my main machine, the launcher starts, but will not update at all.

The culprit seems to be the Agent.exe, i tried deleting multiple times, and ending the process

UPDATE: Now launcher or anything deosnt open, just give an error report :/
Edited by Mithu#1783 on 5/15/2012 7:25 AM PDT
Reply Quote
If you try running the Diablo III Setup.exe file and nothing appears to be happening, check to see if the Windows Service for Secondary Logon is enabled. The game requires it and will not run if it's disabled.

To check, open Control Panel > Administrative Tools > Services and scroll down to the Secondary Logon service. Right click it and select properties. Make sure the Startup Type is NOT set to Disabled. Any other setting is ok.

This service being disabled may also cause the system to appear to hang during the "Updating Setup Files" portion when run.

Have you tried the message above? I had the same problem but this fixed it.
Reply Quote
87 Night Elf Hunter
1480
If you try running the Diablo III Setup.exe file and nothing appears to be happening, check to see if the Windows Service for Secondary Logon is enabled. The game requires it and will not run if it's disabled.

To check, open Control Panel > Administrative Tools > Services and scroll down to the Secondary Logon service. Right click it and select properties. Make sure the Startup Type is NOT set to Disabled. Any other setting is ok.

This service being disabled may also cause the system to appear to hang during the "Updating Setup Files" portion when run.

Have you tried the message above? I had the same problem but this fixed it.


Nah I had to go to my old laptop to install. It isntalls, and runs fine on there. But the specs on it are compele crap. So the game will run really badly.

So I moved the files (the games files) to main PC, now the updater wont run or anything. It just crashses now. It doesnt even open now. But on my crappy laptop the launcher is working perfectly fine and updateing as we speak.
Reply Quote
05/15/2012 07:17 AMPosted by Sìngh
Seriously, Blizz should have delayed the launch until they had all this crap fixed.


So Blizzard should have delayed the launch because you're having an installation issue?

Well aren't you egotistical?
Reply Quote
87 Night Elf Hunter
1480
05/15/2012 07:39 AMPosted by Hostile
Seriously, Blizz should have delayed the launch until they had all this crap fixed.


So Blizzard should have delayed the launch because you're having an installation issue?

Well aren't you egotistical?


Have you seen the amount of people with this issue? Also shouldnt this problem been fixed during the beta? Installing shouldnt be anything that people need worry about.

Anyways, got it work.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]