Diablo® III

Operating system solution for Vista

85 Gnome Mage
5400
So i was getting the common error of "D3 requires a newer operating system" and tried everything i could find here to no avail. if i ran in compatibility mode then i would get the OS error, and if i took off compatibility mode then i would get stuck at "updating install files" (or whatever it said)

Heres how i fixed it:

-set the agent.exe to compatibility mode, and run launcher.
-once its past the "updating files" and the launcher loads DO NOT CLICK INSTALL
-ctrl-alt-del and cancel agent32.exe
-change agent back out of compatibility mode
-reload agent manually from the battle.net folder
-click install

I hope this helps everyone who is in the same shoes i have been in for the past 10 hours.
Reply Quote
85 Gnome Mage
5400
at 35% install now, this work for anyone else on vista?
Reply Quote
How do you set the agent.exe to compatibility mode when it hasn't installed anything yet?
Reply Quote
86 Dwarf Hunter
5080
We have a thread running with this solution listed by Elementor.

I believe it isn't a matter of the compatibility mode but the action of manually stopping and restarting agent32.

http://us.battle.net/d3/en/forum/topic/5051435477#9

hit the other thread and let us know if any of those solutions work. And request the sticky at the top of the thread.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]