Diablo® III

INSTALLER 1% HANGING

Jeah it hangs a long time, but the folder grows, till the installer crashs.

Try to install it on a different HDD on your System (no SSD/no OS)...this worked for me

...i can play (nice intro btw), but the servers are busy atm -.-
Reply Quote
Support Forum Agent
Posts: 35,558
Ohanakahu, I'd do the same with McAfee. Temporarily uninstall it, and try installing Diablo III, then reinstall McAfee afterwards. McAfee has a removal tool as well.
________________________________________________
Support Information
http://us.battle.net/support
'Constant change is here to stay.'
Reply Quote
Now just before I removed AVG to my shock and suprise this install of Diablo III might actually be working...I changed nothing.

Error was not on my side just a slow and painful fix on Blizz end I guess. Its at 5%..and hanging hopefully its gonna work.

If not ill try getting rid of AVG tho if that fails my frustration level will go through the roof.

6%
8%
Edited by Zombius#1128 on 5/15/2012 10:45 AM PDT
Reply Quote
85 Human Mage
9575
Posts: 4
guys its ur firewall disable it
Reply Quote
WRONG I didnt change my firewall and now its working.

Impossible in this case that it was firewall issue. Since its working now.

11%

14%
Edited by Zombius#1128 on 5/15/2012 10:48 AM PDT
Reply Quote
85 Orc Death Knight
2640
Posts: 3
I deleted all existing folders and ran the setup as administrator and it worked for me
Reply Quote
Control Panel
Network and Internet
Internet Options

Connections tab
LAN Settings
Uncheck "Automatically Detect Settings" then hit OK.

Worked for me, although I was stuck at 99%.
Reply Quote
I didnt even run as admin, I just double clicked the DIABLO DISK Icon outta my Drives list thumbnails. And magically outta nowhere (or the blizzard tech finally fixed the issue but are too embarrassed to talk about it openly maybe) its working as intended.

Try it now everybody see it outta nowhere its working for you now.

DO NOTHING SPECIAL...ignorantly double click the disk.
Reply Quote
89 Tauren Druid
4760
Posts: 128
after my post above (from having same issue) im now at 60%+ so give it a try if you haven't.
Edited by exan#1700 on 5/15/2012 10:52 AM PDT
Reply Quote
2 Human Rogue
0
Posts: 840
Control Panel
Network and Internet
Internet Options

Connections tab
LAN Settings
Uncheck "Automatically Detect Settings" then hit OK.

Worked for me, although I was stuck at 99%.

I'm trying to install via digital download, can't figure out what's wrong for the life of me.
Tried multiple fixes, nothing works.
It seems that I was screwed over by downloading in advance, and everybody and their moron brother who downloaded it the day of are playing as I type this.

Thanks for catering to the casuals once more, Blizzard.
For now I'm counting down the days til my Annual Pass ends.
Reply Quote
34% now for me and still going.

DISKS DO STILL INSTALL DATA...THE OLD FASHIONED WAY!!!

**** DIGITAL DOWNLOADS WOOT.

42% now

ITS WORKING AND I DIDNT DO ANYTHING
Edited by Zombius#1128 on 5/15/2012 10:56 AM PDT
Reply Quote
Zombius the reason it "miraculously started working" is because it never stopped in the first place. Your patience seems to be the technical issue, as it seems with most of us.

Granted, the fact that we have to wait this long simply to install a game is bull excrement, but hey, a little bit of patience goes a long way.

you will wait and hour or 2 3, but you'll play for years (if D2 is anything to go by)

Just a lil patience mate
Reply Quote
I re-downloaded the setup file from battle.net then disabled my firewall and it seems to be downloading correctly now.
Reply Quote
Well you get what you paid for and nobody paid me for patience.

48%

But seriously on the topic of patience I let this thing GO AND GO. I went off to drink and have a mini celebration with Pizza and Wine.

Funny thing is it got into its 60%'s last night, then had a totally different error.
Then Refused to Stream
Then this other error where it kinda just said a bunch of crap went wrong and WARNING then it failed.
Then this issue after I deleted everything trying to make fresh attempts for best results.
OUT OF THE BLUE IT WORKS NOW.
Edited by Zombius#1128 on 5/15/2012 11:01 AM PDT
Reply Quote
lol nobody paid you anything, you paid blizzard :/

hold thumbs then :D
Edited by flabber#2689 on 5/15/2012 11:02 AM PDT
Reply Quote
05/15/2012 10:59 AMPosted by flabber
lol nobody paid you anything, you paid blizzard :/


Yes to play Diablo 3 lol my point on the dot.

and im at 55%

Maybe people from this thread can make a nice little raid party and we can QQ about compensation together ; )
Edited by Zombius#1128 on 5/15/2012 11:04 AM PDT
Reply Quote
Exploring the disc and running the setup.exe as admin fixed my 1% problem
Reply Quote
I had this - Seems ti be installing now

I Did
1) Deleted D3 beta data
2) Ctrl+Alt+Del - Under processes stopped "Agent.exe" from running (Its the battle.net updater)
3) Deleted the D3 tmp folders that were created by the 1st install attempt
4 Restarted the install and SEEMS to be working at 6% installed so far... fingers crossed
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]