Diablo® III

Lag issues

Is it just me or is the game running extremely slow? I can get on, but my mms keeps showing around 225-250 and it seems like the monsters are literally teleporting into me.

If it is just me, is there a fix? No outside programs running, etc. Thanks in advance.
Reply Quote
85 Undead Death Knight
3455
Posts: 15
Same problem for me
Reply Quote
A spec of your pc would be nice and what internet connection you have
Reply Quote
yup. identical issue. checked drivers - lowered video settings - prayed - cursed - rebooted - I fire, monster grunts, and then it is in my face while I aim 20 yards away - I think I will have nightmares
Reply Quote
Posts: 6,410
Check your sound settings. Turning my up to High made the entire game run slow. I personally don't have this problem anymore. The release client runs better overall for me.
Reply Quote
perating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120330-1504)
Language: English (Regional Setting: English)
System Manufacturer: Hewlett-Packard
System Model: p6823w
BIOS: BIOS Date: 05/04/11 10:20:28 Ver: 6.07
Processor: AMD Phenom(tm) II X2 521 Processor (2 CPUs), ~3.5GHz
Memory: 4096MB RAM
Available OS Memory: 3840MB RAM
Page File: 2634MB used, 5041MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)

Internet is Bluegrass wireless broadbad. But, playing SC2 there is no lag that even comes close. Thanks.
Reply Quote
And you dont have utorrent running in the background?
I know that was the problem for me with swotor.
And there is proberly a patch soon for solving certain problems if eny.
I am still downloading game client so i have no clue how it will run on my pc

MB:MSI X79A-GD45
CPU:Intel Core i7 3930K 3.2GHz
Ram:16 gb
Grafik :GTX 680 Sli
Win 7 64 bit
1200 W
2 ssd 120 gb
1 2 TB western Digital Caviar Green
Reply Quote
Turn off the shadow quality and and reduce the screen resolution. Those made the biggest difference for me.
Reply Quote
85 Blood Elf Priest
10925
Posts: 17,170
perating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120330-1504)
Language: English (Regional Setting: English)
System Manufacturer: Hewlett-Packard
System Model: p6823w
BIOS: BIOS Date: 05/04/11 10:20:28 Ver: 6.07
Processor: AMD Phenom(tm) II X2 521 Processor (2 CPUs), ~3.5GHz
Memory: 4096MB RAM
Available OS Memory: 3840MB RAM
Page File: 2634MB used, 5041MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)

Internet is Bluegrass wireless broadbad. But, playing SC2 there is no lag that even comes close. Thanks.


I may be blind, but I don't actually see a GPU there. Your video card is probably the biggest potential problem-causer here.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]