Diablo® III

Fps Stuttering

85 Orc Mage
7660
Posts: 67
Also having stuttering issues, assuming stuttering implies the game occasionally freezing for 2-3 seconds here and there, but recovering. I've tried with and without Crossfire and am still having the same issue. I also played Beta with a Core 2 Duo E8500, 8GB Ram, and EVGA 8800GTX system and it did not exhibit this problem. Other games (BF3, MW3, Skyrim, Arkham City) all run on max settings flawlessly. I've tried lower graphics settings and checked my hardware and they are all fine.

Windows 7 64
Intel i7 2600K @ 4.5GHz
Corsair 12GB DDR3 Ram
XFX HD 7850 @ 1050MHz (Crossfire)
Corsair AX1200
I have a monitor with a refresh rate of near 100. When I enter Windowed Fullscreen my FPS go to near 100 but the game feels... sluggish and different compared to Fullscreen.

Interesting dyanmics between the modes and vsync and fps limiter...
Unfortunately the game is unplayable at this state.

dammit...

i7 2600k
GTX580
16gb ram
Windows 7
Me too trawled the internet for fixes no joy at all. Disapointing for a AAA title.
85 Orc Mage
7660
Posts: 67
Also having stuttering issues, assuming stuttering implies the game occasionally freezing for 2-3 seconds here and there, but recovering. I've tried with and without Crossfire and am still having the same issue. I also played Beta with a Core 2 Duo E8500, 8GB Ram, and EVGA 8800GTX system and it did not exhibit this problem. Other games (BF3, MW3, Skyrim, Arkham City) all run on max settings flawlessly. I've tried lower graphics settings and checked my hardware and they are all fine.

Windows 7 64
Intel i7 2600K @ 4.5GHz
Corsair 12GB DDR3 Ram
XFX HD 7850 @ 1050MHz (Crossfire)
Corsair AX1200


Stutters in single player as well.
Edited by Wiggly#1403 on 5/15/2012 5:34 AM PDT
Well seeing that you al have a i7 quad-core hyperthreading CPU. This might be it.

Could anyone try to put the CPU affinity for diablo to only use 2cores without the hyperthreading.
And look if it's any better or worse...

how to:
http://www.techrepublic.com/blog/window-on-windows/change-the-processor-affinity-setting-in-windows-7-to-gain-a-performance-edge/5322

So basically make your machine a dualcore withour hyperthreading.
I actually tried disable hyperthreading, and turbo mode.

With no succes.

I still have to try disabling two cores.... wait...
Posts: 61
Game is horribly laggy on my system with Radeon HD 5970, and AMD Phenom II x4 BE.
Game should come with a warning saying to expect unplayable frame rates without at least an i7 sandy bridge processor cause it's horrible trying to play at 10 fps.
Posts: 45
I get the same thing, and this also happened in beta. The game is horribly optimized where if I move 3 screens over I can hear my hard drive searching for data. I don't understand why it cannot stream or cache this data far more efficiently. I was considering moving this game over to my SSD, but I opted not to because others are saying it does not help.

CPU: Intel Core i5 2500
Graphics Card: Geforce GTX 670
RAM: 8 GB DD3 1600 mhz
Try the affinity settings for the game. Disable 2cores for diablo3.exe
me too, gtx460 and it get choppy when you walk/run and as the mobs come flying in it gets choppier than choppy then it stabalizes once im fighting. As soon as I want to continue on moving it starts stuttering/getting choppy again.

I thought it were my old drivers at first, as the game said I might experience problems during gameplay. But I guess drivers dont help, having read this thread.
same.
Also can anyone with 2 screens and with the stutter problem open op the task manager and monitor the CPU usage, Memory Usage, HDD usage.

how to:
http://www.youtube.com/watch?v=5cotYlSL6mg

should give us some insight on whats happening on the stutters.
Disabling 2 cores actually helped me.

Then i went back to 4 cores, no HT, no Turbo.
Game ran better now???

Is this a server problem? because my latency was better at these two tests.
I'd wondered myself about latency... in fact last night I thought the problem was 100% network lag and expected it to be fine today... Then double checked and found this thread and MANY other posts all over the place about this issue (so now I'm not so hopeful!).

For me it seems that the graphics don't stutter as such but more like the game itself pauses so that, for example I run over gold, it stays put and then vanishes a few tenths of a second later whilst the player animation continues uninterrupted.

Last night it "felt" like game information was being sent off to battlenet and my character was waiting for a response from that before anything actually happened. I'll check tonight and post..

Game running from SSD
i7 980 (6 core)
x12Gb
GTX 580
Win7 x64
Edited by Dworkin#1413 on 5/15/2012 6:22 AM PDT
Posts: 1,252
Core i5 760 + GTX460 here. No stuttering. NOT using latest drivers, 295.xx if I remember correctly.

Then again, I have D3 on my SSD. I purposely moved it there to avoid situations like this. It could also be latency related, which would suck for those of you without good internet.
As far as I see it's a quadcore problem. Mind you I also have a i7-920 and don't have the problem. I did however have it when entering tristam right at the beginning of act 1.
I see many i7's with this problem...
And a AMD Phenom II x4. So i see alot of quad-cores
This topic has reached its post limit. You may no longer post or reply to posts for this topic.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]