Diablo® III

Low FPS on Mac still a problem

I'm running on a MBP. The game was playable through the first act, but by midway through act 2 I started averaging about 4 fps. I have all the settings and resolution as low as they go, and I meet the minimum system requirements. I quit all applications in the background. I don't really notice any performance difference when I set the graphics to a higher setting. It just is glitchy all around.

Even playing on my PC is not ideal. I feel like the game could use a good deal of optimization on both platforms.
Edited by solrenoid#1161 on 5/29/2012 3:46 PM PDT
Reply Quote
05/29/2012 09:59 AMPosted by Shocker
I think its Laptop hardware not the video card like we think. I hear that if you run the game on a 16gig USB flash drive it clears all the problems up. I'm gonna buy one tonight so i'll keep you updated.


Wasted my money trying this. Don't waste yours.
Reply Quote
Forget about the pen drive stuff. I'm running on SSD 240GB facing the same problem.
Reply Quote
05/29/2012 04:23 PMPosted by Marrock
I think its Laptop hardware not the video card like we think. I hear that if you run the game on a 16gig USB flash drive it clears all the problems up. I'm gonna buy one tonight so i'll keep you updated.


Wasted my money trying this. Don't waste yours.


wow...really?
Reply Quote
2009 imac / 9400 user, it's playable but still get 15 fps sometimes on minimal settings/window, which is not satisfactory.
Edited by redstone#2234 on 8/7/2012 8:01 AM PDT
Reply Quote
10 Draenei Hunter
2215
Posts: 1
Alright everyone, I was encountering the same problems on my late 2010 MBP. I spent the majority of the day yesterday dealing with several technical support people, and I found a solution (it worked for me at least). Here are the steps I took, given to me from bliz tech support.

1) Good morning!

Lets make sure that your system is running the game client on your dedicated graphics card and not integrated card.

Download and install the following:

http://codykrieger.com/gfxCardStatus

Run it and select your dedicated graphics card. :)

Let me know if this helps.

2) I do still have a few tricks up my sleeve. Lets start with this article from Apple and then we'll move forward from there: http://support.apple.com/kb/HT4110

3) First, reset your SMC: https://us.battle.net/support/en/article/resetting-smc

4) Then reset your PRAM: https://us.battle.net/support/en/article/resetting-pram

5) Once these two trouble shooting steps are done, reinstall your combo update for 10.7.5 as this will reinstall your divers: http://support.apple.com/kb/DL1582

- I didnt see results until steps 3-5 were completed, but figured I would post them all up just in case. I hope this helps everyone!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]