Diablo® III

Downloader isn't launching the installer.

I got to 7.6gig of 7.6 100% waited for a couple of minutes and closed it which I now read was a big mistake.

Anyway, re launched the downloader, done all the files, and everywhere says to wait and allow the downloader to auto launch the installer.
Ive been sat here now for 20 minutes with the downloader saying at the bottom of window "finished downloading installer" like last time, and still, no installer launched. I don't want to close the window again, for the sake of more downloading.

Anyone else been sat waiting the installer to launch and it hasn't? Or how long should it take?
Reply Quote
Posts: 9
http://us.battle.net/d3/en/forum/topic/4926594052

The first one worked for me.
Reply Quote
same here bud, leave it on for another hour, do something els in the meanwhile. people saying that you just need to have patience.

Greets
Reply Quote
It took 32 minutes for it to finally launch the installer,

I just hope no problems with the installer like the problem ive just had.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]