Diablo® III

"The game connection has been lost; your clie

D3 worked fine the first day and yesterday/today I've been having the same problem... I def. think its on your end BLIZZARD!!! HELP US OUT!
Reply Quote
I was having the same problem getting kicked every 30 seconds to 5 minutes and then I read on here that joining general chat had allowed some people to stay connected, so i tried it and it worked for me. I was able to play for hours without getting kicked (other than when the servers went down) for the first time. I had tried everything Blizz suggested and nothing but this worked. Fixed the problem for my girlfriend too.
Reply Quote
05/17/2012 08:41 AMPosted by Contention
I was having the same problem getting kicked every 30 seconds to 5 minutes and then I read on here that joining general chat had allowed some people to stay connected, so i tried it and it worked for me. I was able to play for hours without getting kicked (other than when the servers went down) for the first time. I had tried everything Blizz suggested and nothing but this worked. Fixed the problem for my girlfriend too.


not working for me.
Reply Quote
Game is unplayable i keep getting disconnected

-You have been removen from the game.
-The game connection has been lost ,your client has been disconnected from the server.
-You have been removed from the game

!@#$TTTTTT!!!!!!
Reply Quote
just got this 5 minutes ago really pisssing me off every couple hours i get this
Reply Quote
I have been getting this too, it really makes the game unplayable. I get disconnected sometimes within 30 seconds of resuming a game, not enough time to get to the next checkpoint. It is fine with my new character going through normal. The disconnect happens with my nm barb.

Also this started ~8am yesterday, I had just entered nm. Come on blizzard do something, or let us know you are working on it at least.
Reply Quote
First day no issues, yesterday everytime I got to a boss it would disconnect before the fight started. Finally got up to Diablo last night with my mates, with whom I have better connection speeds and guess what disconnected again. Today has been fine however mid level tonight I got disconnected and displayed the same message each time "connection to server lost you have been disconnected from this game" Weird thing is my internet is fine?

Can you imagine how much I was raging last night not being able to fight Diablo!!!!

Blizz sort it!

ASAP!!!!
Reply Quote
Started today for me, could not exit a dungeon.

when you dc the dungeon resets, get back in, i get dc, dungeon resets.

3 hours wasted and have not gone anywhere

In for info.
Reply Quote
Looks like server restarts and patches has not fixed a thing. My one toon still disconnects after 1-5m.
Reply Quote
85 Draenei Warrior
4775
Don't worry guys, just check your router settings. You've obviously done something different between now and 2 days ago to cause this problem...not Blizzard. After you check your router settings, call your ISP because if it's not your router it's most likely 100% the fault of your ISP. Maybe your connection isn't fast enough, maybe your ISP is over loaded. Don't blame Blizzard though, they never make mistakes.

I'm not sure what's worse, the fact that D3 is a $60 piece of garbage for many people at this point or that Blizzard is actually trying to tell us that our router settings and ISP is the cause?


Yeah what's with all these dip!@#$s saying it's the router. I found someone saying it's DEFINITELY A D LINK PROBLEM guess what I use an apple time machine for internet and that %^-* is smooth as hell. I can load up any of 15 online games right now and the only one that will DC is diablo 3. AWFUL for single play experience what a joke.
Reply Quote
85 Tauren Paladin
2135
Also experiencing this issue and my router is fine. Really think it's not on the players end and would love a blue post addressing this problem or that they're atleast AWARE.
Reply Quote
Im directly into my modem

no probs till today

What i have found is, if i stand still or walk around a area and do not find a mob its fine. No dc.
If i walk to a mob and play as normal within 10 mins it will dc.

Congestion?
Edited by Abigdeal#6995 on 5/17/2012 9:42 AM PDT
Reply Quote
I have the same problem "error 3007" it only started occuring when I got into nightmare difficulty. I tested creating another character and I can play hours without a problem on new character. However, I switch back to my original character and I still get the same 3007 error every 5min. Seems like this is definently something wrong w/ server side and not my computer.
Reply Quote
90 Draenei Mage
12350
i get the same the game connection was lost. randomly. and it is really frustrating. Fix this blizz!!!
Reply Quote
Wow... really, Direct connecting to MODEM is the very solution for this probelm.

After connected directly, never kicked out from the room by the same reason...

BUT, what cause this kind of ridiculous problem? Remove router for playing game?

Do I really have to do this crap, everytime I play this? OMG OMG OMG
Reply Quote
stuck in act 3 normal - raise the catapults. both me and my brother wizard and barb. we get booted out at the beggining of quest all the time......really sux !!!
Reply Quote
I'm still unable to play the game, getting the "game connection has been lost" error every time I try to resume game. My total playing time since I've bought the game - half an hour before I exited the first time I've played.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]