Diablo® III

"The game connection has been lost; your clie

Jin's approach may or may not fix disconnects, but it did absolutely nothing for lag. The game still lags when someone joins or when I try to teleport to someone, and it's definitely on Blizzard's side since I've tried multiple graphics and sound settings, and my internet runs fine for everything else. Besides, it couldn't be my internet if it lags specifically and not just out of the blue.
So a new patch that I can't play because of constant disconnects.....This is not an internet provider issue!

The last week and a half, I can not play more than 10 mins. without being DCed. So yeah, the valor buff....I can't get it to 5. WTF! I'm now starting to get angry. I have been playing since day one. Switched to a TR build on my Monk about a month ago and for the last week and a half nothing but non-stop disconnects.

You would think for the people who have actually stuck around for the game they could at least make it playable. Honestly, I was ready for the new patch and now I'm considering just walking away all together. This is unacceptable Blizzard! Release a new patch that can't be played because of DC's....another awesome job not well done.

Blizzard always looks to blame your internet provider when they know it's an internal issue. Again, I played for 7 months without 1 DC, and within the last week an a half I can't play for more than 10 mins. FIX IT NOW!
If anyone has figured out why this occurs or how to fix it please chime in! Already Lost a hardcore character because of it. Would be nice if the blues would at least comment on it..I also never had 1 DC up until a week ago.
Edited by HawK#1714 on 2/12/2013 11:58 PM PST
This thread was started 5/15/2012 and is still an issue. I get kicked to the menus at least 6 times an hour if I play on my WW Barb or my Tempest Rush Monk. My computer is not a Tandy TRS80 and my internet connection is rock solid.

This has been going on for about a year now. Blizzard please address this, give the illusion that you give the slightest s**t about your customers.
Blizzard if you are not concerned about fixing this or even simply addressing this issue in a simple forum post, please consider extending the reset of the NV stacks for like 5 minutes or something upon disconnects due to your servers network instability.
Edited by synthox#1280 on 3/2/2013 3:10 PM PST
Blizzard won't address be cause the majority of this problem is not something they can fix.

There is info on the WoW forums about this same issue if you care to dig. It seems the CMs and tech support are much more proactive there.
Blizzard ignoring this post again as expected.
So I wanted to post this because I started getting this error this week, but I seem to have resolved my issue.

My issue started after I manually updated all my drivers through control panel on Windows 7. One of the only drivers that actually updated was my Belkin wireless adapter. But I didn't think about the drivers until after I tried a variety of other troubleshooting methods. I stumbled on this thread while I was looking for a solution.

So I tried logging on with different characters, different acts, different monster power settings. The issue first appeared to occur whenever I would would try to switch the monster power, and I was able to make it occur less by changing quests and starting a new game instead of resuming my old game to reset the act. But then it kept happening again.

I ran Blizzard's repair tool, power cycled my router and modem, did some overdue maintenance on my PC like cleaning the registry, and I even put new cooling paste on my CPU because that's solved bizarre technical issues in the past. Nothing worked, I was about to reinstall the game but then I remembered that I had updated drivers. So I uninstalled the driver for my wireless adapter, and reinstalled it with the CD that came with it. Sure enough, my issue seems to be resolved. Apparently the default drivers on the CD are better than the "updated" drivers that were obtained through Windows update. Not sure if that will help anyone else out, but that's what solved my issue.
i have been getting this exact issue from about 3 patches ago and thats from my high speed cable connection, never happened before 3 patches ago but has been annoyingly doing this since then wish they would fix this crap.
I have tried many things also but the fact it only started after a patch usually leads to another patch that fixes some crap and breaks others, good work team.

It only kicks randomly from a game i have created back to character screen not right out of it which makes getting 5 buffs up to kill keymasters very damn annoying.
Edited by Crankie#1400 on 3/11/2013 3:03 AM PDT
I've got same problem since 2012 may, once it was alright for couple months, than in about December last year i cant play longer than 1 hour (if im lucky). I was trying different things port forwarding, all this little bullsh*** that blizz suggest, I tried with few ethernet cards and im still occuring same issue. I thought maybe today's patch will fix something but than i got dc'ed after 30 min of run. I bought collectors edition and it fells like waste of money. The only good thing about it is that i have more time for real life. Blizzard sold me a big dissapointment.
same here with my barb in mp10 inferno breached 2 always disconnects.. :(
Ok, going to add my name to this list. Haven't been playing for a few months, and when I played before this wasn't an issue. I am also using Belkin wireless networking on my computer. I was before, too. My wife is playing with a hard-line to the router, and she doesn't get kicked off. Going to try Shrek's solution and see if it makes a difference. Will keep you updated.
Heh... Figures, that's the ONLY device driver CD that isn't where it's supposed to be in my box of stuff. Shrek, what is your driver version number?
Update: went into Windows and instead of reinstalling, rolled the driver back to 5.60.180.11. Time to see what happens.
I only get this problem when running my TR monk. running window mode did bypass the problem for me.
Calling the problem resolved for me. A dozen hours or so of playing over the last few days, no disconnects.
03/29/2013 11:59 AMPosted by Razorback
Calling the problem resolved for me. A dozen hours or so of playing over the last few days, no disconnects.


not me.. still getting the constant disconnects.
I have belkin wireless and I just remembered that the card acted weird the other day. I'll change the slot and see what happens.

It did not help and I have the same driver as the above poster.
Edited by Sapien#1344 on 3/30/2013 5:41 PM PDT
Revisiting this, I hadn't tested this out with my whirlwind barb. Didn't realize until now that people were having problems with this, specifically. So I loaded this chr back in, played for about 20 mins or so (just enough time to build up 5 stacks of NV and be in the middle of fighting Belial) and I got booted. The error I got this time though was Error 74, the one that says there's a battle.net outage. Was able to reconnect just fine, but the driver rollback didn't help with this issue after all. I was testing it with the wrong character.
This topic has reached its post limit. You may no longer post or reply to posts for this topic.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]