Diablo® III

"The game connection has been lost; your clie

85 Blood Elf Paladin
13530
Posts: 110
05/16/2012 12:58 PMPosted by MOANS
Please fix the disconnect problem. The easiest solution would to actually make single player a true single player. I get the whole not wanting people to hack your game but when I can't play due to your inability to manage your own network it makes me never want to buy a blizzard product again. Didn't you learn from SC2? You make fantastic games yet continually disapoint during every release. What was wrong with keeping the multiplayer on a server and having single player separate? Now I'm limited to playing D3 only when i have internet connection. What happens if i'm traveling and i want to play, or say i'm somewhere where there is no internet as I often find myself. Try and remember that many things that look great on paper fall apart during execution.


This solution would not be a fix for the problem at hand. I'm trying to play with multiple friends across the country, and I'm the only one having this issue out of the group of people I'm playing with.

That being said, there is someone playing in my house with me, in the same room, and he is *not* getting this disconnect issue. I don't quite understand how it could affect someone in the same room, but not the other person. It has to be something client-side?
05/16/2012 02:22 PMPosted by Valthonis


Disproven I'm afraid, I'm an EU player but this is the biggest thread I could find on this problem!


Seems american players can play fine on euro servers but euro players can't play on their own servers. Try playing on the american servers? yea all my friends play on the american servers too... but at least this way i finally get to play the damn game.


Literally just applied that logic to see if I could play on American servers... still have the same problem ¬.¬
85 Blood Elf Paladin
13530
Posts: 110
Just to clarify here, as I was linked to this thread from another (similar, though possibly different issue) thread; the people here are getting disconnected from their game, but not battle.net entirely, correct? ie, You can still talk to your bnet friends, and immediately rejoin the game you were just in, even if all of the experience/gold/items you've acquired since the last login disappeared?
Posts: 59
Same here
90 Tauren Warrior
5760
Posts: 6
I started DCing late last night during the black soulstone quest... I haven't been able to pass it because i get half way done and it DCes every time. It really frustrating me becuase i play wow and everything runs smooth, im at 58 ms latency on D3, but it just randomly shuts off. WTH is the problem bliz.
Posts: 6
ok same EXACT thing same mission everything disconnects me everytime.
85 Blood Elf Paladin
13530
Posts: 110
It sounds to me from reading these posts that there are possibly two or more different issues happening for people here, though the majority it seems are people playing through Act 2.

My specific issue, at least, has been happening all throughout Acts 1-3, and is not occurring on any specific quest/character. Thus far, it has also only happened while I am hitting or getting hit by an enemy, though that may have just been coincidence (as there is not much time while I'm playing that I'm not getting hit).
Posts: 6
i was also running off a wireless netgear. trying to plug straight into modem now to see if anything fixes this :/
Posts: 18
It sounds to me from reading these posts that there are possibly two or more different issues happening for people here, though the majority it seems are people playing through Act 2.

My specific issue, at least, has been happening all throughout Acts 1-3, and is not occurring on any specific quest/character. Thus far, it has also only happened while I am hitting or getting hit by an enemy, though that may have just been coincidence (as there is not much time while I'm playing that I'm not getting hit).


I'm having your exact issue and passed through Acts 1-4 normal yesterday without a hitch. Today I am randomly getting disconnects randomly, while in Nightmare Act 1. It's also been happening to me while playing through Act 4 Normal with a friend.

I don't think there's a correlation between what you're doing in the actual game client and when you get the disconnect. I certainly haven't noticed one. Sometimes I'll be taking a teleport to town, 90% of the time I'll be in a fight.

For reference, the window should say "Network Disconnect" at the top and the message should be "the game connection has been lost." You should be teleported to the select character screen afterwards, and you should be able to hit resume game almost immediately (only to be disconnected again shortly thereafter).

If someone could make a more constructive OP/thread outlining this it would be fantastic.
85 Blood Elf Paladin
13530
Posts: 110
05/16/2012 02:52 PMPosted by Flame
I'm having your exact issue and passed through Acts 1-4 normal yesterday without a hitch. Today I am randomly getting disconnects randomly, while in Nightmare Act 1. It's also been happening to me while playing through Act 4 Normal with a friend.


I did get this disconnect one time last night, shortly after the hour and a half downtime around 1:30 PDT. Everything was smooth after that though, until today.

I've been playing through Normal with my boyfriend (confirmation that this isn't only a Nightmare issue), and it's been happening with infuriating frequency. I do agree, though, that this thread should be split into two new threads, better outlining each issue as it stands. Throwing a collage of problems that sound the same but really aren't into a single thread isn't really helpful to anyone.
Posts: 18
05/16/2012 02:57 PMPosted by Chry
I'm having your exact issue and passed through Acts 1-4 normal yesterday without a hitch. Today I am randomly getting disconnects randomly, while in Nightmare Act 1. It's also been happening to me while playing through Act 4 Normal with a friend.


I did get this disconnect one time last night, shortly after the hour and a half downtime around 1:30 PDT. Everything was smooth after that though, until today.

I've been playing through Normal with my boyfriend (confirmation that this isn't only a Nightmare issue), and it's been happening with infuriating frequency. I do agree, though, that this thread should be split into two new threads, better outlining each issue as it stands. Throwing a collage of problems that sound the same but really aren't into a single thread isn't really helpful to anyone.


It sounds like the downtime that was hailed as the "service update" is what started these constant network disconnects for a bunch of people. I only played for a few minutes after that updated was released, but went through the entire game with no errors before it. Suddenly, after it's released, I get a torrent of these errors.

I don't even care if the error is on my end at this point, I just would like a response to figure out how to fix it.
Just played on the European servers for a bit without a single disconnect. Came back to the americas, and got Dc'd within a minute.
Posts: 1,374
05/16/2012 03:00 PMPosted by Flame


I did get this disconnect one time last night, shortly after the hour and a half downtime around 1:30 PDT. Everything was smooth after that though, until today.

I've been playing through Normal with my boyfriend (confirmation that this isn't only a Nightmare issue), and it's been happening with infuriating frequency. I do agree, though, that this thread should be split into two new threads, better outlining each issue as it stands. Throwing a collage of problems that sound the same but really aren't into a single thread isn't really helpful to anyone.


It sounds like the downtime that was hailed as the "service update" is what started these constant network disconnects for a bunch of people. I only played for a few minutes after that updated was released, but went through the entire game with no errors before it. Suddenly, after it's released, I get a torrent of these errors.

I don't even care if the error is on my end at this point, I just would like a response to figure out how to fix it.


Agreed, I would like a response from Blizzard as well for a potential fix, or at least a "we are aware of the issue and are looking into the source" or whatever.

Becuase This is stupid, I can't play anymore.

The interesting thing is, it's not a issue with my connection, because I have a roommate and we are playing together, and he hasn't been disconnected at all, but I've been disconnected randomly over 20 times in the past 2 hours. I can't play for more than 5 minutes without getting DC'd at this point. We are just roaming around Act 2 in Nightmare killing stuff waiting on a friend to get back and I'm the only one suffering the DC issue, he doesn't and we live in the same house.

Blizzard response or something please, this is making me very angry.


It sounds like the downtime that was hailed as the "service update" is what started these constant network disconnects for a bunch of people. I only played for a few minutes after that updated was released, but went through the entire game with no errors before it. Suddenly, after it's released, I get a torrent of these errors.

I don't even care if the error is on my end at this point, I just would like a response to figure out how to fix it.


Agreed, I would like a response from Blizzard as well for a potential fix, or at least a "we are aware of the issue and are looking into the source" or whatever.

Becuase This is stupid, I can't play anymore.

The interesting thing is, it's not a issue with my connection, because I have a roommate and we are playing together, and he hasn't been disconnected at all, but I've been disconnected randomly over 20 times in the past 2 hours. I can't play for more than 5 minutes without getting DC'd at this point. We are just roaming around Act 2 in Nightmare killing stuff waiting on a friend to get back and I'm the only one suffering the DC issue, he doesn't and we live in the same house.

Blizzard response or something please, this is making me very angry.


It must be something to do with out clients, it's the only thing that makes sense! I have to say I was completely shocked to find no repair tool or anyway of validating my game files within Diablo III
So Chry, the person in the same room, he/she connects wirelessly or by cable (and how do you connect yourself to the network). Is it the same network? Different OSs?

I don't really think I have the wits to figure out the bug while knowing absolutely nothing about D3's implementation, but we can always try >.> (obviously I also have the same problem, but I'm the only one to play D3 in my region, so I can't quite make the tests and comparisons).
Same question for Stiria :<
network connection here
80 Human Warrior
570
Posts: 112
This is in regards for a constant error of code 3007.

I've read over and over on various forum threads of Error 3007 Lost Connection. And to be quite frank from every Blizzard response, it is nothing more then the exact same thing over and over. Either a 'Self-Troubleshooting Guide' is recommended OR, we get told it's a user error of some sort. So for you BLIZZARD, allow me to shed some light on this very fast growing problem.

Error 3007 is a 'LOST CONNECTION' Error that shows for a rapidly large growing number of players with constant posts and new threads being made over and over. So, here is my first question. IF this Error 3007 is a user error and trouble shooting is the simple fix, why does the number of received errors grow? How can it be user related when so many suffer it?

World of WarCraft and StarCraft2 Players have not complained about loosing connection, it's just the loss with this game. Everyone has been saying the same thing. I will rephrase for better understanding. "ALL GAMES THAT REQUIRE ONLINE ACCESS TO PLAY WORK PERFECTLY FINE EXCEPT FOR DIABLO 3"

I play World of WarCraft and Diablo II BattleNet all the time and nothing is wrong with either. Never do I get disconnected. I run Steam from Valve and all my online games work just fine. The fact I am here making this post shows I am online.

Here are some factors BLIZZARD to show that this constant growing error is NOT user related and is NOT a simple 'troubleshooting fix'.

Factor #1: High Volume of players from all over the world play this game. We are not all in the same house, on the same router, or on the same provider.

Factor #2: ISP is varied from player to player. Some run Comcast, Charter, Frontier, DSL, Cable, or FiOS. Meaning that everyone single player aside from one's in the same house have their own set up regardless of provider.

Factor #3: Router and Modems. Some players are connected directly from the computer to the modem, others go through 1 or 2 routers. Some have D-Link, Linksys, Netgear, Belkin,Dynex, or some other brand for a router. Whether the router is wireless or not should NOT matter if the player has a direct LAN connection to the router. Being wired or wireless depends on how they connect to the internet NOT what router they use. [I cottaced Blizzard Support via phone and they asked me the router and I told them a wireless but I had a wired connection and we were going through steps to help get a better wireless connection. Complete incompetence.]

Factor #4: IP Addresses. Everyone has one if you are connected to the internet, everyone's is different no matter what. So if this is still a user related error for our 'Loosing Connection' how do we change this? Well simple answer you can't. So safe to say that everyone with an internet connection has an IP address, so, a 'User Realted Error for this lost connection can be started here in knowing...We as the players in this mass group are not responible for the lost connection.

Factor #5: how the game was obtained. Some have downloaded it from buying it from from the website, other got it with the annual pass of WoW, others got a standard edition of the game, others got the Collectors Edition of the game. So Loss of Connection Errors being ruled from this is ridiculous.

NOTES:
Complete power cycling can help, yes. Ensuring your router's firmware is up to date, yes. Making sure ports are set aside for D3, yes. These are all three some factors that MAY increase the stability of your connection, but as with most, it does not.

I do not want to have to go out and buy some really really expensive router and get a bunch more cat7 cables just to play this game. Every other online game works fine, not a single connection error at all.

URGENT!
BLIZZARD: Every other game works fine, WoW, SC2, Diablo 2. The connection for the servers work fine, no disconnection at all!

As some have said with so many variables with this, ISP, IP Addresses, modem styles, router styles, network cards(whether added on or the on board default), ethernet style cables, the difference in either wireless or wired connection, so many are different for every single person, but ONE thing and only ONE thing is the same. Where we are all receiving this Error 3007, through BLIZZARD on Diablo 3. (Not WoW, not SC2, not D2, Not any other internet required game, JUST Diablo 3)

So please, any blizzard representative who is reading, don't give me a guide for trouble shooting, it doesn't work. I've spent the last day and a half trying to figure this out and there is no answer. I've exhausted every method of my own knowledge, the ones I found here, even called to get additional help and nothing worked. So many other deal with this same exact problem.

Theory:
Server Bug. In the emergency maintenance work some scripting along the way has gotten messed up. At least something has been plagued. Fact is there is something with the Diablo 3 server that fails to keep a connection with the player and closes. At first I could understand some of us having it and it require mere troubleshooting and we as the players couldn't hold the connection with the server, but now it's still continuing. Many people have spent $60-$100 and many haven't been able to make their first character or even see the game yet. This cannot be something as simple as troubleshooting, especially with such a high growing number. Instead of taking time to research troubleshooting ideas to post that have already been exhausted, get a team to investigate the server scripting itself and find where this bug is and why people keep getting disconnected.
Posts: 223
I keep getting disconnected every 5 mins, my net is absolutely fine, I am watching a stream without the game lagging, but It keeps booting me off to my character selection screen.
your conspiracy is off-topic and won't help us solve the matter at hand :C
This topic has reached its post limit. You may no longer post or reply to posts for this topic.

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]