Diablo® III

Equipped Templar with shield

51 Human Hunter
230
Posts: 92
Now I can't play because I disconnect every 2-3 minutes. I wasn't aware of this game breaking bug till after the fact (blizzard, you didn't do a good job telling us about it...). Is there anyway you guys can fix this? Thanks.
Reply Quote
90 Blood Elf Paladin
11020
Posts: 18
Did they fix this? I am using the Templar and would like to upgrade his shield
Reply Quote
Blizzard Employee
Posts: 2,130
We fixed the Templar bug around 1 am PST on May 15 with a hotfix. Whatever disconnects you are experiencing are not because of the Templar bug.
Edited by Vasadan on 5/16/2012 9:20 PM PDT
Reply Quote
Having searched the EU forums and not found an update, was this hotfixed on the EU servers too? Don't want to try it until I have seen confirmation of it. (Templar Shield Bug)

Thanks
Aurn
Reply Quote
Blizzard Employee
Posts: 2,130
Having searched the EU forums and not found an update, was this hotfixed on the EU servers too? Don't want to try it until I have seen confirmation of it. (Templar Shield Bug)


It was hotfixed globally :)
Reply Quote
Speedy reply, thank you Vasadan - to the Templar!
Have a great day!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]