Diablo® III

D3 Visual settings and Nvidia Control Panel

sorry for this long list of settings that i will provide below, it's just that i want to get the best possible performance for my game while also keeping the great visuals and special effects.

with my current settings listed below i get smooth 60 fps for the most part with occasional framerate hiccups here and there especially when fighting lots of monsters but even while running in open space with no monsters nearby. if anyone can suggest which of these settings to change to get more consistent 60 fps i would very much appreciate it. thanks!

first here are my specs: Asus G53 SW 15.6 inch 1920x1080 gaming notebook

windows 7 64bit home premium with SP1
i7-2630 QM @ 2 GHz but can be clocked to 2.8 GHz (high performance mode)
GTX 460M with CUDA 1.5 GB (dedicated VRAM with current driver 295.73)
8 GB RAM

first i will list how i'm currently running D3 with my current in-game settings in bold font:

display: fullscreen, windowed, fullscreen windowed
resolution: 1920x1080 16:9 widescreen
letterbox (display in widescreen aspect ratio regardless of res): unchecked
vertical sync: checked
max foreground fps 150: unchecked (not sure what to put here)
max background fps 8: unchecked (not sure what to put here)
texture quality: high
shadow quality: off
physics: high
clutter density: high
AA: checked
low fx (decrease number of rendered particle effects): checked

for my Nvidia Control Panel, under Manage 3D settings -> Program settings -> D3:

ambient occlusion: off
anisotropic filtering: applic. controlled
AA-gamma correction: on
AA-mode: applic. controlled
AA-transparency: off
CUDA-GPUs: all
maximum pre-rendered frames: 3
multi-display/mixed GPU acceleration: multiple display performance
power management mode: adaptive
texture filtering-anisotropic sample optimization: off
texture filtering-negative LOD bias: allow
texture filtering-quality: quality
texture filtering-trilinear optimization: on
threaded optimization: auto
triple buffering: off (v-sync is enabled in the game however)
vertical sync (v-sync): use the 3D applic. setting

also in Nvidia Control Panel, under PhysX configuration, by default i have auto-select (recommended) for the "select PhysX processor" and it gives me 3 options: 1. auto-select (recommended), 2. GTX 460M (GPU), 3. CPU

thanks a lot for for your help! i know this is pretty heavy on the technical side, but any little help will be highly appreciated :)
Reply Quote
90 Tauren Death Knight
8470
Posts: 4
Your vsync will keep your fps at your monitor's framerate, which is 60hz. Uncheck vsync and you'll get more than 60fps.
Reply Quote
Also change texture filtering quality from quality to performance. It will drop the smothe edges of things but it should run with less hiccups.
Reply Quote
Hi undeaddragon,

how is your gaming now?

I am experiencing slowness during fights especially with parties having huge amount of effects.

virtually identical PC but my VC is GT 540M.

How was ur gaming now? Anything that you tried that your gaming is so smooth now? Please share. Thanks
Reply Quote
thanks a lot this is the only thread that could help me, everything works perfect and setting the game to "fullscreen" helped the most. Thank you good sir !
Reply Quote
you followed his settings?
Reply Quote
Guys sorry about this. I need your help as I am experiencing slow during the game when I have a party playing Diablo 3.

My Laptop:

ACER ASPIRE 4755

Processor: Intel (R) Core (TM) i7-2630QM CPU @ 2.00 GHz 2.00 GHz

Installed memory (RAM): 8 GB

System Type: 64 bit OS

Video Card: NVIDIA GEFORCE GT 540M CUDA™ 2GB

I followed "undeaddragon's" settings in NVIDIA control panel however problem still persist.

IN GAME SETTINGS:

display: fullscreen
resolution: 1920x1080 16:9 widescreen
letterbox : unchecked
vertical sync: checked
max foreground fps 150
max background fps 8
texture quality: high
shadow quality: off
physics: high
clutter density: high
AA: unchecked
low fx : checked

ambient occlusion: off
anisotropic filtering: applic. controlled
AA-gamma correction: on
AA-mode: applic. controlled
AA-transparency: off
CUDA-GPUs: all
maximum pre-rendered frames: 3
multi-display/mixed GPU acceleration: multiple display performance
power management mode: adaptive
texture filtering-anisotropic sample optimization: off
texture filtering-negative LOD bias: allow
texture filtering-quality: quality
texture filtering-trilinear optimization: on
threaded optimization: auto
triple buffering: off (v-sync is enabled in the game however)
vertical sync (v-sync): use the 3D applic. setting

also in Nvidia Control Panel, under PhysX configuration, I select GT540 M

PLEASE HELP WHAT SETTINGS IS THE BEST FOR MY LAPTOP so that I can't experience slow playing during party especially during the skills of the wizards.
Reply Quote
Wth.. OP is asking for help to get hi's game to peak performance and every reply is saying thank you? ROFL
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]