Hello,

I have Vista Home Premium (SP2) w/ all the latest updates. DiabloIII won't install and the message simply says that my OS does not meet the minimum requirements. My nvidia drivers are also totally up to date.

I tried to install using compatibility mode option but no dice. The game does install nicely on my son's machine which has windows 7. The box says it should be able to run on my Vista machine so I'm a total lost. I really hope that I don't have to upgrade to Windows 7 in order to play this on my rig. I have never had an issue with other game regarding the OS requirement.

Any ideas would be greatly appreciated. THanks.

yarbles