Diablo® III

Start Menu Won't load

Posts: 2
Whenever I try to start the game everything seems fine, music starts, but then I just get stuck in a blackscreen with the music playing, the start menu never loads. The game doesn't crash and a simple 'Esc' will get me back to my Desktop.

I have Nvidia GT 540 with updated drivers so I don't think that's the problem. I've tried Administrator mode with no luck.

Any ideas?
Reply Quote
90 Undead Priest
10515
Posts: 1
Same problem here. Any help would be great. Come on community!!
Reply Quote
I am having the same problem - with the exception of sound. I'm not getting that. I press play and it stops on a black screen.

I have a Mac... But if anyone suggests that's my problem I'll probably go ape. =]
Reply Quote
Just kidding - found my problem. I need a new graphics card... Eff my life.
Reply Quote
Posts: 2
Heard McAffe can effect it, so I uninstalled that, still no luck. Tried adding -opengl to the end of the target field to see if it's a Directx problem but nothing.

Please help
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]