Diablo® III

I seemed to fix the fps problem so far

Posts: 22
hold down option and select go in finder

Went to library -> Application Support -> Blizzard -> Diablo III -> edited D3Pref.txt

changed
DisableTrilinearFiltering "0"

to

DisableTrilinearFiltering "1"

and changed

ChannelsToUse "32"

to

ChannelsToUse "16"

I was only able to test it for 30 mins but saw a difference... Please back up this file before use... Let me know if this worked for you! If it does I'm very glad to help :)
Reply Quote
I would definitely like to see some blue input on this possibly temporary workaround (at least until a real fix comes about).
Reply Quote
I second that. Can anyone verify it as a fix/work around? Especially with a 9400M graphics card?
Reply Quote
I tried… there was no noticeable difference to performace.

Thanks for being productive, though. :)

(on a NVIDIA 9400M)
Edited by nantris#1185 on 5/16/2012 9:20 PM PDT
Reply Quote
Posts: 55
im going to sleep, but il try tomorrow
Reply Quote
Posts: 22
You have to reset your computer though, this is using the 9400m. It seems once its slow you have to reset it. Hope it works! The fps is still simi bad but its a lot more playable on my end.
Reply Quote
Confirmed on '10 macbook pro. Enormous improvement in performance. Very much obliged for the hack, OP.
Reply Quote
Posts: 22
Great glad to hear :) hire me blizzard lol
Reply Quote
I'll give it a restart and try again, then.
Reply Quote
90 Undead Mage
5200
Posts: 73
I cannot find the file you're editing. When I hold on option then select go on finder I do not have any files saying 'Library'.
Reply Quote
I can't find this file either.
Reply Quote
Open Finder, hold Option, then click Go on the top bar on the screen, then click Library.

Having said that, I just tried it (with the restart of the computer) and saw, maybe, very minor improvements, but probably none overall. Still very poor performance on the 9400M card. Bummer.
Reply Quote
Posts: 55
restarted, no noticeble diference on 2009 mini with 9400m
Reply Quote
It was hidden in Lion. Before that it was available in Finder.

I tried it but saw no difference in performance. The FPS seemed to jump around a bit more but still averaging the same.

PS. change channels is available in the Options GUI under 'Sound'
Reply Quote
Posts: 22
Make sure your holding down the option key, then hit go in finder. The library option is hidden unless you hold it down
Reply Quote
Posts: 22
The gain to me was in multiplayer. After 5-6 mins it would get to choppy to play. Doing this for me made it playable at highest resolution, but low everything else. I was only able to test it for 30 mins and had to leave for work :( I was excited that i was able to finally really play :)
Reply Quote
Posts: 55
wait, you are playing with the 9400m and in higher ress, im on 800x600 with everything in low, and i cant play single player
Reply Quote
So i found the file, changed them both and unfortunately saw no changes. Thanks for the effort though.
Reply Quote
So it looks like there is a potential fix for some systems but not all. Perhaps there is more at play here.
Reply Quote
I tried this with what appeared to be minimal improvements in play. I was actually able to kill the boss where the second sword piece was supposed to be.

All in all the game is still unplayable. Literally.

I wish I could record the video of how the game plays, but if I try to do any of that the game wouldn't even work I'm assuming. My guy runs so slow...it's ridiculous, I can't even see what's going on half the time.

Sometimes I get a moment in a cellar or something when I can actually run at what appears to be full speed, and even on 800x600 resolution with everything on low or off, that moment is like pure bliss. Just RUNNING like I'm supposed to. That's not what should make me enjoy a 60 dollar game.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]