Diablo® III

Pixelation Lighting Effects Fix ATi HD Series

90 Blood Elf Mage
8780
AMD has finally released full version drivers 12.6 for HD 5000 series and Up, and also now have 12.7 Beta's avalible.

As of 12.6 AMD has changed how they handle the drivers for HD 4000,3000 and 2000 series cards, they have stated this "AMD Radeon HD 4000, AMD Radeon HD 3000, and AMD Radeon HD 2000 Series have been optimized to their maximum potential from a performance and feature perspective." and now their intention is only to "resolving application specific issues and critical updates"

You can read the full article and even download the 12.6 Beta drivers for those series Cards here:
http://support.amd.com/us/kbarticles/Pages/catalyst126legacyproducts.aspx

I have a new fix here:
12.4b drivers work to stop the pixelation issue but you half to take an extra step to get the problem to go away.

First off download the 12.4b drivers here:
http://support.amd.com/us/kbarticles/Pages/AMDCatalyst124bhotfix.aspx

Now then you must completely uninstall your current drivers you are using, when finished you will be prompted to restart, click No.

Go to your device manager, then go to display adapters. Under display adapters right click on your ATI video card device and select uninstall, when prompted too confirm the uninstallation (dont bother with the check box asking to delete you dont need to).

By doing this it will revert your screen to a low res VGA setting running without video card drivers. Now reboot your system, once loaded up run the 12.4b driver installation once finished, reboot once more and your screen resolution will be back to a higher setting (adjust if you need).
This should fix the pixel issue and Diablo 3 will be running just fine. I have done this myself on my HD 3870 card, it is working great.

For those wondering I havn't try'd the 12.6 beta drivers (that are specfic to HD 4000,3000 and 2000 series cards) yet to confirm if this method fixed the pixel issue as well but anyone is more then welcome to try.
.
.
.
.
.
.
.
.
.
~~~~~~~~~~~~~OLD POST:~~~~~~~~~~~~~

Hey everyone,

Anyone with an ATi HD series card has been reporting Pixel blocks around lighting effects.
This has to do with the ATI Video card drivers, the fix unfortunately is to roll back to a much older driver version, ive been testing all the packages and found you need to roll back all the way to the 2010 September release to fix these issues, hopefully AMD has this fixed with their 12.5 driver release.

But for now you will need to download the 10.9 driver package, uninstall your current drivers, reboot, install the older ones, reboot once more and the issue is gone (it is important that you do a full uninstall and reboot before doing the driver downgrade as it will not downgrade properly if you just run the old installer on top of your newer drivers). Hopfully using these older drivers doesn't cause issues with other newer games but since the HD 3800 series card is pretty old it will probably be fine.

32bit Driver Download Vista/Win7:
http://support.amd.com/us/gpudownload/windows/previous/10/Pages/radeon.aspx?os=Windows Vista - 32-Bit Edition&rev=10.9

64bit Driver Download Vista/Win7:
http://support.amd.com/us/gpudownload/windows/previous/10/Pages/radeon.aspx?os=Windows Vista - 64-Bit Edition&rev=10.9

People have reported having this issue on the follow series of cards:
HD 3200, HD 3400, HD 3600, HD 4200, HD 4300, HD 4500, HD 4600

So far Working on:
HD 3400, HD 3600, HD 3800, HD 4200, HD 4300, HD 4500, HD 4600

If you have one of those series cards try this fix and see if it works for you as well.

Blizzard if your reading this maybe sticky or add to one of your current stickys?

EDIT: I noticed lagging too with the 10.8's specially in WoW, when I was testing the 2010 releases I went down to 10.6 first it worked so I went up to 10.12 it didnt, so I went in increments of 2, 10.10 didnt work 10.8 did and I stopped there. I just switched to 10.9s the fix is still tehre and also fixes the video lag I was experiencing.
Edited by Keiichi#1273 on 7/7/2012 10:46 PM PDT
Reply Quote
mine is HD 4300, your suggestion was perfect, now no more pixelated errors, thank you so much! =)
Reply Quote
90 Blood Elf Mage
8780
Awesome glad to hear that, added 4300 to the list.
Reply Quote
Hey everyone,

Anyone with an HD 3800 series has been reporting Pixel blocks around lighting effects.
This has to do with the ATI Video card drivers, the fix unfortunately is to roll back to a much older driver version, ive been testing all the packages and found you need to roll back all the way to the 2010 August release to fix these issues, hopefully AMD has this fixed with their 12.5 driver release.

But for now you will need to download the 10.8 driver package, uninstall your current drivers, reboot, install the older ones, reboot once more and the issue is gone (it is important that you do a full uninstall and reboot before doing the driver downgrade as it will not downgrade properly if you just run the old installer on top of your newer drivers). Hopfully using these older drivers doesn't cause issues with other newer games but since the HD 3800 series card is pretty old it will probably be fine.

32bit Driver Download Vista/Win7:
http://support.amd.com/us/gpudownload/windows/10-8/Pages/radeonaiw_vista32.aspx?&lang=English

64bit Driver Download Vista/Win7:
http://support.amd.com/us/gpudownload/windows/10-8/Pages/radeonaiw_vista64.aspx?&lang=English

People have also reported having this issue on the follow series of cards as well:
3600,4200,4300,4500,4600

So far Working on:
HD 3800, HD 4300

If you have one of those series cards try this fix and see if it works for you as well.

Blizzard if your reading this maybe sticky or add to one of your current stickys?


This is only for the desktop range, anyone have a link for the 10.8 mobility drivers?
Reply Quote
85 Troll Hunter
8215
Will attempt for HD 4200, as nothing else has worked so far.
Reply Quote
3200 is also having the exact same problems.
Reply Quote
Have an HD3850.

Can report that 10.8 works great.

Thanks for testing all the drivers Isis!
Reply Quote
86 Night Elf Rogue
5105
Have HD 3850x2, and this worked for me.

The game did seem to stutter more, although I only tested it for a minute or so. In any case, I'll take a little stutter over things looking all sorts of messed up.
Reply Quote
I just finished trying this with a Radeon HD 4200.

It solved the problem but it also made the game lag like woah.

Probably not the best solution for us 4200's. Thanks anyway for the tip.
Reply Quote
I am about to give this a try to fix my problem. I also have the same problem with shallow water while playing WoW, hopefully this will take care of that too.
Reply Quote
Thank you so much Isis, it was such a pain... Worked perfectly for the HD3850.
Reply Quote
86 Draenei Shaman
6665
the good news is knowing that the update following 10.8 is where the problem began, ati and blizz will have a much easier time identifying what change to the driver is causing the issue and hopefully we will soon see a hotfix for the hd3800 as there has been for the other cards
Reply Quote
I am using an hd 3600 and downloaded this driver, it did fix it for me but it does lag a wee bit. Thanks.
Edited by SgtChronic#1720 on 5/16/2012 6:36 PM PDT
Reply Quote
90 Blood Elf Mage
8780

This is only for the desktop range, anyone have a link for the 10.8 mobility drivers?


Unfortunatly laptop drivers are made by the manufacturer since the GPU chips are built into the laptop as a whole and you would half to look at your product support page of your laptop and see if they have older drivers.

I just finished trying this with a Radeon HD 4200.

It solved the problem but it also made the game lag like woah.

Probably not the best solution for us 4200's. Thanks anyway for the tip.


10.9 should fix the lag while maintaining the D3 Fix. Remember to fully uninstall the 10.8s first then do the 10.9s Updated links in the first post.
Reply Quote
90 Blood Elf Mage
8780
05/16/2012 02:53 PMPosted by Scarydrew
the good news is knowing that the update following 10.8 is where the problem began, ati and blizz will have a much easier time identifying what change to the driver is causing the issue and hopefully we will soon see a hotfix for the hd3800 as there has been for the other cards
]

Yeah I have narrowed it down to the 10.10s is where the problem starts hopfully ATi/Blizzard can use that information to fix the issue.

Use 10.9s instead of 10.8s stuttering/lag is fixed when using the 10.9s links updated in the first post.
Reply Quote
85 Undead Priest
5965
Any word on a 10.8 or 10.9 ATI Catalyst Mobility version?
Reply Quote
90 Blood Elf Mage
8780

Unfortunatly laptop drivers are made by the manufacturer since the GPU chips are built into the laptop as a whole and you would half to look at your product support page of your laptop and see if they have older drivers.


05/16/2012 08:42 PMPosted by Riseup
Any word on a 10.8 or 10.9 ATI Catalyst Mobility version?


I quoted a previous post I recently did about that.
See if your laptop maker has anything old enough. AMD doesnt make regular drivers for mobility cuz of issues it could cause with the laptops, however AMD recently put out "generic" ones that they offer thats new towards laptops, however when looking at it, they only offer the latest releases i.e. 12.4 and it comes with a detector to see what you have and to give you the newest generic ones which wouldnt fix the problem :/

Im hoping AMDs May release of drivers has these issues fixed as using these older ones have made some issues come up here and there.
Edited by Keiichi#1273 on 5/16/2012 10:12 PM PDT
Reply Quote
You are a lifesaver! I never saw some mobs that used to kill me, but now the problem is fixed!!! Thanks Isis!
Reply Quote
86 Troll Priest
7090
Isis, my ticket was answered by Blizzard and I linked them your forum post and told them to sticky and comment on it so that people know more about how to fix this problem. you are amazing! I hope you get the recognition you deserve!!
Reply Quote
90 Blood Elf Rogue
12960
HD 3870. 10.9 works! Thanks for the post!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]