Diablo® III

STEEL SERIES MOUSE

Did anyone else purchase the steel series D3 mouse. I plugged mine it and it worked fine while D3 was installing. Read instructions with the mouse and went to the SS website to download the instructed download for the mouse....The mouse stopped working and now has the center led, above the cpi button, blinking........Any advise.....please help
Reply Quote
That sucks, I hope you can get it working!
Did you install the official software for it? If so, note that sometimes they recommend that you install software before plugging in the mouse. Otherwise, try unplugging it and plugging it back in.

If you try some simple troubleshooting and find that it still doesn't work, you should contact Steelseries about it... The mouse is obviously very new, so I am sure they can replace it for you if needed.
Reply Quote
From SteelSeries Support

1. Refer to the picture in the link below and make sure that you are not plugged in to any of these places. The USB 3.0 port is OK to use but try using both a 3.0 port and 2.0 port. Since 3.0 provides more power, it may be the better alternative.
http://cdn.steelseries.com/userguides/Support/AVOID_USING_THESE_USB_CONNECTIONS.jpg

NOTE: If you do plan to change ports, first uninstall the SteelSeries Engine with the devices plugged into their original ports that you had them plugged into during installation.

2. Make sure that your USB devices are set to be powered up at all times and that any power saving features are turned off.
Please refer to this thread for further information (steps 1 & 2 apply for all Windows OS, step 3 is ONLY for windows 7 users):
http://windows7themes.net/mouse-not-working-after-hibernation.html

3. Kill the SteelSeries engine process (steps below)
a) ctrl-alt-del -> processes tab
b) Find SteelSeriesEngine.exe and select 'end process'

4. Download the following tool, right click -> run as administrator -> run the fix for your product
http://cdn.steelseries.com/engine/SSEFix_1.17.8.6.exe

If it still doesn't work, try the FW Upgrade on another computer.
Reply Quote
@meehow2p I love you thanks for fixing my mouse you are the best!
Reply Quote
I suggest a steel series mouse pad

i love this thing!
Reply Quote
Thank you very much, that worked out.
Reply Quote
at 11 % i always get cannot open bootloader device doesn't matter which version
Reply Quote
03/12/2013 08:16 AMPosted by Samsoniteous
at 11 % i always get cannot open bootloader device doesn't matter which version


Have you fixed your issue?
Reply Quote
100 Blood Elf Paladin
5955
Posts: 1
im still havint this issue demigod my moue gets stuck to 11% then just says failed to bootloader blah blah so frusterating
Reply Quote
@Psychpally did u fix it? Im having the same problem
Edited by Mueretee#2263 on 6/17/2014 9:04 AM PDT
Reply Quote
did you guys found a way to fix this, same problem here, tried everything, it already happened once a few months ago and could fix it by deleting every steel series engine file and reinstalling on mac. but that solution is not working now.. any help? thanks
Reply Quote
I have the same problem at 11% now my mouse wont work. :(
Reply Quote
90 Human Mage
955
Posts: 1
all right guys i had the same problem at the moment and i found a way to fix it,for those who have the steel serie engine programe there is an update tools. i was crashing at 11%, unplug it then click again they gonna ask you to make sure the mouse is plugged.then retry it should work. if it dosnt work im sorry but i cant help more.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]