Diablo® III

Mouse Cursor disappears

100 Troll Mage
17775
Posts: 52
Having the same problem, using a Mac Powerbook OS X 10.6.8. I do not play in windowed mode ever. Very hard to exit the game when this occurs and often losing progress in Inferno mode is so painful :( Since everything one shots you going back really stinks.
Reply Quote
Posts: 1
This is happening to me also.
Reply Quote
100 Dwarf Hunter
9885
Posts: 139
I can confirm this issue as well on my Mac, both in D3, and in WoW. It happens in WoW quite often, and I have to relaunch the game to fix it. I am very disheartened to see this bug pop up in D3. It has happened in D3 six times since launch day.

I am losing my faith in Blizzard.
Reply Quote
I suffer from the disappearing cursor issue as well... You can make it reappear by opening your inventory and selecting an item. This works for me, not sure if it will be the same for others...

[Running in Windowed Fullscreen - Windows 7]
Reply Quote
I'm playing on a new 8 GB Mac Powerbook (running OS 10.7.4 Lion), using a wireless Targus mouse (Model #: AMW5701USZ), and have been playing Diablo 3 since release. D3 has been running fine until this cursor issue which has started to become a bigger problem.

Main issue; I can't get it to pop back up when playing full-screen. It seems to happen with inventory item; dragging or picking up, over burdened, etc. Mouse works for clicking to a location, but is not parsing visually. It's incredibly frustrating.

The vanishing cursor phenomenon is happening so frequently, that I'm starting to not even bother to play anymore. Being that I got the Collector's Edition box set, it's really turning into a disappointment. Please fix this in an upcoming update. I'm starting to feel totally screwed over between the crashes and mouse issues.
Edited by AIX#1646 on 6/2/2012 4:06 PM PDT
Reply Quote
Posts: 4
this happens on my 2011 mbp running lion everytime i use my "rat 7" mouse. I have never had this issue with my logitech g5. Just for fun I just tried my rat 7 again and the issue still persists.
Try a different mouse.
Reply Quote
90 Dwarf Hunter
4910
Posts: 1
I don't have a cursor what so ever showing when im playing D3 and this the first day its been happening and it is quite annoying alright. Im using a brand new pc laptop i just bought a day ago.
Edited by JuicyJay#1279 on 6/3/2012 9:23 PM PDT
Reply Quote
Same problem here - using a cordless Logitech mouse with a current iMac 27".
Reply Quote
Just read through this thread.... so is there a solution??

Im having the same issue.
Reply Quote
4 Undead Rogue
0
Posts: 3
You can make it reappear by opening your inventory and selecting an item. This works for me, not sure if it will be the same for others...


This worked to fix the issue for me. Thanks Ronin!
Reply Quote
Same thing has been happening after update. Using 2011 late MBP, I have to pause the game and alt-tab out and back in to see the cursor again.
Reply Quote
This has now started happening to me after the update, not before the update. If anything the update has only made things worse. For me, anyway.
Reply Quote
Exact same problem, on my 2010 macbook pro 13", but I think the issue only occurred when there was an occasional bit of lag (normally rubber-banding). Happened twice in the same dungeon (easter passage, in the waterway in the dalghur oasis), and the only fix is restarting the game. Playing in fullscreen btw.

EDIT: Mac OSX 10.6.8
Edited by CptFantastic#2847 on 6/8/2012 7:11 AM PDT
Reply Quote
90 Night Elf Druid
8725
Posts: 1,434
Same problem here.

Running 2.66 ghz intel core duo imac version 10.6.8
4 gig ram

I run on full screen with settings turned way down.

Mouse keeps disappearing on me.
Reply Quote
Clicking on an inventory item seems to fix this issue for me
Reply Quote
Same problem happens once in awhile MBP 2011 Mac OS x Ver 10.7.4 2.4 GHz 8GB. Its annoying as hell try to reboot. Gonna try the inventory thing next time see if that works for me
Reply Quote
Happens to me at least once every 2 hours, I end up having to command-tab out and back into the game 2-3 times before it works again. Well the cursor in gone it's impossible to click anything
Reply Quote
90 Pandaren Rogue
8375
Posts: 1
reinstal wow stil same problem on Window 7
Reply Quote
10.7.4 retina mac. usually happens when i cmd+tab to firefox and back. only fix i've found is to restart. inventory selection doesn't seem to affect it.

Thanks
Reply Quote
I am running Mac OSX lion. The mouse keeps disappearing on me while I am fighting Belial. Is there a patch for this, or is there a graphics settings that I can turn down to prevent this from happening?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]