Diablo® III

jumping back to desktop

Sryz guys, i misled u, but obviously i tryed soo many things, so i wasn't sure, witch worked, but after a few hour testing, the real cause came out:


seriously, who thought about that....

Reply Quote
Hi guys,
After releasing latest patch, 1.08, this issue has come aas my heaadache. And it doesn't help that I am started to get interested about HC at the same time:) I have tried the suggestions in this threat, but don't work for me:
-Close Skype
-Disable antivirus

All ideas highly welcome!
Reply Quote
MVP - Technical Support
Posts: 25,762
View profile

Jumping back to desktop means either you are hitting the windows key or some other software on your machine is taking priority. You are right, this is definitely something you want to resolve before trying HC! Your quest will be to find that rogue software and eliminate it. To help you do that, you can boot into Selective Startup mode which means most processes, including your firewall and antivirus, won't be running. You can then enable things one by one and see which one causes the game to minimize. Instructions are here https://us.battle.net/support/en/article/shutting-down-background-applications
Reply Quote
Hey All

I suffered this same issue for a while so I decided to try a few things.

Seemed like a priority thing, so -

1. Turned off all system tray programs, didn't work
2. Turned off auto updates for Windows, didn't work
3. Started Task Scheduler and deleted all scheduled tasks, they are not needed anyway. All good, haven't jumped back to desktop since.

Hope this helps others too.
Reply Quote
got the same issue. Game was fine until the latest patch.

It's ok disabling things on the PC but I didn't have to do that before the patch. Question is what changed in the patch and how long before Blizzard get it put back. Should not have to disable everything on my pc.
Reply Quote
Posts: 10,222
View profile
got the same issue. Game was fine until the latest patch.

It's ok disabling things on the PC but I didn't have to do that before the patch. Question is what changed in the patch and how long before Blizzard get it put back. Should not have to disable everything on my pc.

i doubt anything changed that would cause this.
even windows updates will cause the game to minimize back to desktop.

the easiest way around this mess is to play in Windowed (Fullscreen) mode.
if you want to stay in Fullscreen though then you are going to have to find out what is minimizing your application.
Reply Quote
If memory serves me right there used to be a way to change the priority settings for programs. So that when you change the settings you make Diablo III take precedence over all Programs.
Edited by GreatGambini#1340 on 10/25/2013 9:26 AM PDT
Reply Quote
I have a catch 22. Running in windowed fullscreen fixes the problem for me, but windowed fullscreen has a higher chance of crashing. I can't afford a crash or a "jump to desktop" in hardcore so I need a solution for this. Disabling all background tasks hasn't worked for me.

I have always had this problem since the game launched across 3 different computers. All 3 computers had unique parts except have only used 2 graphics cards, which are the HD6850 and the HD7970
Edited by nightshark#6285 on 11/5/2013 4:17 AM PST
Reply Quote
I think the issue was solved for me by opening up CCC from the background tasks and minimising it.
Reply Quote
Task Scheduler revealed Adobe Updater running once every hour. Turned it off. Will see how that goes.
Reply Quote
I had this issue but resolved it by doing clean Windows 8.1 install from dvd. Suggest whenever doing NVidia driver install -- choose custom install / clean. Also suggest partition your hard drive (20gb) and place d3 on it. That way if you ever clean install, there is no need to download d3 again. Just create shortcut to desktop.
Reply Quote
My Diablo3 suddenly began returning to desktop out of nowhere.

It turns out that I had just upgraded Samsung Drive Magician. After exiting the program I could play Diablo again.

So look for programs that run in the background, and turn them off one by one.
Reply Quote
i am sure this happens when my cursor hits the right edge of the screen while playing. please help fix this bug instead.
Reply Quote
Try to install the new launcher for the game, the battle net launcher. I had the same problem and I tried several things as updating the video card drivers and so. Nothing worked, but after installing the new launcher, the game runs normally without going to the desktop. Hope that helps!
Reply Quote
Sooo..after dealing with the same problem i finaly found out what caused that..dont use some RaLink, TP Link or whatever wireless utility on tray bar..close it and maybe this will avoid that switching,like in my case
Edited by warko666#2405 on 5/21/2014 11:17 AM PDT
Reply Quote
90 Human Rogue
Posts: 4

same problem over and over in westmarch.

error codes similar to one above. (each one is specific to a time when game drops to desktop)

drops as in game closes and you get to start over.

at least you save loot and level up...

happens anywhere in the zone.

after 4 to 6 minutes in drops to desktop, restarts the quest. cannot finish westmarch.

Not video, not my pc, not the connection.

fix it blizz.
Reply Quote
Same thing is happening to me as of... today. Fun, I tell ya.

Game does not crash, but display goes back to desktop. It actually does it even when I type this. Characters I type stop appearing on screen, maybe three or four at a time, as if I clicked away from my window for a second. Weird. So it's definitot the game, but a process that's diverting the attention of the whole fricking computer back to desktop, regardless of what it's doing at the moment. (example of this, "definitot", which I typed earlier, was supposed to be "defenitely not", but skipped 5 characters...)

Reply Quote
Solved it. Apparently, something on the USB key that was plugged in was triggering my VPN, which kept on crashing. Even after uninstalling all instances of VPN-related software.
Reply Quote
I tried the methods above, and did not work; in my case, Battle net application itself was cause. As a quick fix, go to setting, and select Exit Battle.net completely under WHEN I LAUNCH A GAME.
I did not experience the jump-back since then. Try it and if it works for you, report it here so technical support pay more attention to this bug and get it fixed permanently.
Reply Quote
05/21/2012 03:37 AMPosted by B4N4N
same here, every 30 minutes! it'll be annoying on hardcore mode ;/

...It is.. ;)
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Explain (256 characters max)