Diablo® III

Agent Requires OSX Admin Login?

Support Forum Agent
Try this:

    1. Force quit any Diablo III, Agent and Blizzard Launcher processes in Activity Monitor.
    2. Navigate to /Applications/Diablo III.
    3. Delete the D3Debug.txt file.
    4. Reset the Diablo III game folder permissions.
    5. Launch Diablo III.
  • If the game prompts to enter in your administrator username/password, hit Cancel.
  • If it doesn't it should load fine.
  • 6. Diablo III should load.
Reply Quote
Just wanted to say THANKS! to Machkhan - this^ solution worked like a charm :3
Reply Quote
Tried the suggestions above and none worked. For anybody still having this problem herre is one more thing to try which fixed it for me:

1. Open "/Users/Shared" folder in Finder.
2. Select "Blizzard" folder.
3. Select "File --> Get Info" from menu
4. Click the lock icon (bottom right corner of Info window) to allow you to make changes
5. Under "Sharing & Permissions" make sure you have Read/Write
6. Select "Apply to enclosed items..." from the Gear dropdown (bottom edge of the Info window, near the left)
7. Repeat steps 2-6 for the folders "Battle.net" and "Blizzard Entertainment"

I was having the "Agent wants to make changes" issue for myself and the kids. Works for everyone now.
Reply Quote
Support Forum Agent
This should of been resolved. If you are still getting the prompt for user name and password, please enter it in so the new tools update can apply and resolve the issue.

If this still does not work, please delete the Battle.net folder in users/shared and launch D3 again to get a new set of tools.
Reply Quote
This last suggestion worked for me as well (deleting the D3Debug.txt file) . Thanks!
Reply Quote
90 Gnome Warlock
9295
Same problem. Its very annoying.
Reply Quote
Support Forum Agent
Did you try to delete the Battle.net Tools folder and try again? It should only prompt 1 last time and that it.
Reply Quote
I fixed this issue by:
1) Right click "Diablo III" and choose "Duplicate"
2) Delete "Diablo III"
3) Rename "Diablo III copy" to "Diablo III"
Reply Quote
Deleting the shared folder did the trick for me. Thanks!
Reply Quote
90 Undead Death Knight
10265
It is simply not correct that the dialog only comes up for updates. I just reinstalled WoW on my machine and every single time I launch the game I get an authentication dialog, The game is up to date according to battle.net app, and I simply cancel that authentication dialog (after entering my user/pass at least a dozen times) and this is on an admin account.

On my normal account, and on the account my kid uses, the dialog ALSO comes up every single time the game is launched, but the admin/pass must be entered. every. single. time.

The only thing I've ever seen that fixes this, mostly, is going into the terminal and

chmod -R a+w /path/to/wow

but since Blizzard creates new launchers outside the wow folder *ALL THE TIME* this only helps some.

Everyone at Blizzard should be required to use WoW only on standard non-admin accounts, then this stupidity would end.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]