WOrked instantly after I changed this. First off game was trying to update. but was stuck.. just doin nothing. not letting me play and not updating crud... on Win7... open control panel. Administrative tools/ services.. go down to Secondary logon.. If its disabled... change it to automatic... I had to do this to install the game even. but something must have changed it at a latter time. .and Just not i wasnt able to log in or finish the update... I change that setting back.. and Instantly worked... Hope it helps . MusTurd... Over n out