Diablo® III

Can't play diablo

I click on the icon and open it, then i let it install updates and when its 100% i press play and it says launching and then doesn't do anything. cant press play again just says launching but isn't doing anything
Reply Quote
I have the same issue. Updated my drivers and it still doesn't work.
Reply Quote
yeah, my friend is having the same issue just would like to know if it will work later or what the problem is?
Reply Quote
hey just reinstall it that worked for me
Reply Quote
Posts: 1
I have tried reinstalling 3 separate times and still the same issue. Even tried using the blizzard game client download instead of the disc and still nothing. It says it is running in the process abut not in the tasks of the task manager app, but can't see it on the screen. Anyone have a solution for that?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]