Diablo® III

(conflictmanager::createobjects)

when i'm installing i always get this error:

error: the folder "C:program files\diabloIII.temp" could not be created. (conflictmanager::createobjects)

im running on windows 7, i let the program run as administrator, checked the compatibility settings, and all but still get this error please help
Reply Quote
wow after three days of waiting, still no reply on this thread... does this mean i bought the game for nothing? T^T please help...
Reply Quote
I have the same problem aswell:/
Reply Quote
ConflictManager:CreateObjects

hi everyone, i spent hours trying to install d3. first i had the problem of "updating setup files" which is stuck at 33%. and i found the fixes by digging so much in the internets i couldve reached hell and back.
you can find the list here.
http://www.keenandgraev.com/2012/05/12/diablo-3-stuck-updating-setup-files-fix/
#5 worked for me, where i downloaded a copy of the setup files and extracted the zip file on
"C:\ProgramData\"
which should contain "C:\ProgramData\Battle.net"
the folder should have 3 folders inside:
Agent, Client, Setup. (where Client is the one that got stuck during the Agent launcher).

If you can't find the folder above, then it's because ProgramData is hidden. please just do yourself a favor and search for how to "Show hidden folders in <OS>".

After i got through this, i encountered the error when Diablo III installation started. it only went up to 0% and prompted this:
"C:\Program Files (x86)\DiabloIII.temp". (ConflictManager:CreateObjects)

And this might mean that the user doesnt have permission to write in the program files folder. which got me puzzled since im an Administrator, and i just installed my OS.
And it's Windows 7 Ultimate 64 bit

I had no choice but to reinstall my OS again! using Windows 7 Ultimate (the 32 bit Version!)
and i crossed my fingers and spent hours again without sleep to wait for installation.. blah blah..

And then finally, i did Diablo 3 installation again from the start (same error as the initial part) and then got to the launcher part, where it went from 1% to 69% (and i again encountered another "stuck in oblivion" where the percentage wasnt moving)..
turns out, it was just the Internet Options.

go to your internet explorer > (Menu) Tools > Internet Options > Connections (tab) >
click LAN Settings (below) > uncheck "Automatically Detect Settings" > OK.

you can do the last set of steps above even during 69% or 77%. and then you will see that in a few minutes it will continue downloading.

And after 10 hours of installation.. hope you share this info if it helps you.
Thanks,!
Reply Quote
thank you very much @triggerhappy! i would've gotten stuck at 77% as well if not for your very informative "walk-through" i will forever be indebted... after 2weeks of trying to install this (in between working and sleeping) i have FINALLY completed it... your help is VERY MUCH APPRECIATED.

@charmless, try disabling UAC if your on win7... that fixed the "create object" error for me... then do as trigger happy says... hope this helps you out as well ^_^

*(you can type "User Account Controls" on the control panel search button to find it)
goodluck and see you in the game!!! wooohooooo!!!!
Reply Quote
90 Orc Warlock
5425
Had the same problem updating and install World of Warcraft. Happened to come by this post searching for the the error message I was receiving. This solution worked for me as well.
@Triggerhappy Thank you very much, this saved me from pulling out the rest of my hair.
Reply Quote
yeah, ugh, i tried what @triggerhappy suggested and it didn't work. btw, i'm running Windows 8... is this game known to have any issues with that OS?
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]