Diablo® III

Mouse-over FPS drop issue (workaround)

On an eVGA GTX 465 on 301.24 beta drivers (though rolling back 3 versions didn't fix the issue).

This may be related to the "FPS stutter" threads, though my issue didn't have to do with loading of assets. I was getting a weird problem where mousing over NPCs, loot, monsters, portals, etc. was causing my FPS to drop from 60 to 30, EVERY time. I ran an onscreen display and noticed that every time I moused over anything that required the game to put the colored "glow" around the NPC, monster or item, my GPU usage would go from 86% to %55 or so. With vsync on FPS would go from 60 to 30 and stay there. Moving the mouse away always made it shoot back up to normal.

Rolling back NVIDIA drivers did nothing. I had to turn off AA if I wanted vsync to stay on. If I turn vsync off, then AA works fine. Just can't have both on for some reason. Seems like a rendering bug with the way the engine draws the "haze" or "glow" effect around moused-over elements.
Edited by AeonGrey#1964 on 5/17/2012 1:34 PM PDT
Reply Quote
Posts: 17
Play in windowed (fullscreen mode)
The issue will be solved.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]