Diablo® III

tempest rush/tailwind bug

There seems to be a bug where after i activate tempest rush/tailwind and travel a short distance my character transports back to where i first activated the rune, and from there on if i try to continue in the direction (either by running or by using tempest rush, any sort of movement) i was traveling when i activated the rune, i will glitch back to where i started, sort of like an infinite time loop. i've tested this in town and it continues on and on forever, at least until i try another direction, which sometimes doesnt work either. i hope i've explained this well enough.
Reply Quote
85 Troll Druid
6155
I've also noticed this, you actually have to tempest rush out, then left click in the same direction, then pause, then u can turn and use another ability, otherwise you get ported right back to the starting position just as mastacre said. It gets extremely aggravating when using tempest rush to get out of a group of mobs, just to have it port you right back into the desecration AND you still spend the spirit. This def needs to be addressed blizz
Reply Quote
I'm seeing this as well.
Reply Quote
Fix tempest rush + tailwind rune please.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]