Diablo® III

Workaround for Command - Q quitting D3

MVP - Technical Support
100 Draenei Mage
7170
Posts: 18,996
So Q is the default keybinding for potions and if you accidentally press Command and Q at the same time it quits your game. /sadface

But even if you rebind Q you can still quit the game by accidentally pressing both at the same time.

This appears to be because Command Q is bound in the menu item for "Quit Diablo III"

I think i've been able to figure out a workaround until it gets fixed.

** Work around starts from below **

In OS X Lion you can remap the key combos of programs. If it's in a menu I understand it can be remapped. I'm not totally sure if this feature is available in the other versions of OS X.

You get to it via System Preferences -> Keyboard -> Keyboard shortcuts (Tab)

Click on Application Shortcuts.

Click the Plus Icon at bottom right

In the sheet that pops up :

For Application scroll down the List to "Other..."

Navigate to Diablo 3 folder. Select the Diablo 3 app.

Menu Title is "Quit Diablo III"

You must get the menu title correct and exact for it to work. Note those are capital I's at the end there.

For Keyboard shortcut - Assign something like and complicated that you know you'll never use and Blizzard would never assign to anything. Like Shift Control Option Command Clear.

If you've done it correctly you'll see a "Quit Diablo III" under "Diablo III" with a string of symbols representing the key combo you've chosen. If you've done it incorrectly then it will still have the Command - Q key combo showing.

Now launch Diablo III and when it loads go into Windowed mode via Command M. Or via Options -> Video -> Display

You should now see that in the File Menu "Quit Diablo III" is no longer Command - Q. It should now be the weird combo you assigned above (you know the one that you'll never use anywhere on your mac in a 1000 years :P)

Or rather it should be :P

Pressing command and Q together should now not quit you in game.

Apologies if this is a little unclear. I'm a bit tired and about to pass out. I'll see about doing another editing round to make this a little bit clearer and possibly adding some photos and uploading it somewhere i can have pretty photos and stuffs
Edited by bluspacecow#1174 on 5/16/2012 5:20 PM PDT
Reply Quote
Thanks, works perfect.

Tried this out previously, but didnt have "Quit Diablo III", thats the key.

Now to figure out how to disable "Command+Left Click = Right Click"...
Reply Quote
MVP - Technical Support
100 Draenei Mage
7170
Posts: 18,996
Thanks for trying it out. I had a feeling that people were ignoring me.

05/17/2012 03:11 PMPosted by TheDHC
Tried this out previously, but didnt have "Quit Diablo III", thats the key.


It need to match the name of the menu exactly.

You'll know because it has a string of symbols after the entry in the Keyboard pane and it should show the same string of symbols when you pull down the File Menu in D3.

Playing in Window mode of course but isn't essential to make this workaround work. It's just to check if it's worked or not.

05/17/2012 03:11 PMPosted by TheDHC
Now to figure out how to disable "Command+Left Click = Right Click"...


Disable it ?

Isn't that the Disable System short cuts button in the Gameplay screen of the Options screen ?

Not in game atm so can't remember the exact name of it.
Reply Quote
Disable Mac Shortcuts doesn't seem to disable the "Command+Left Click = Right Click"

I think its in the Mac OS for people with a one button mouse, to right click, but I have a 5 button mouse so its not necessary.

I use the Command key as the "stand still" and hold it down when battling, been doing it since D2, and have become very accustomed to it. Works great for me with my barb for better aiming, and so Im not running around if I miss target something.

I swear it worked fine in the open beta weekend, because I was real worried that it wouldn't.

Heres a forum discussion about it that I can only find on Googles cache:

http://webcache.googleusercontent.com/search?q=cache:h_5i2d6pwpQJ:https://us.battle.net/d3/en/forum/topic/4662316397+command+left+click+mac+%22disable%22&cd=1&hl=en&ct=clnk&gl=us&client=safari
Reply Quote
90 Undead Warrior
7770
Posts: 2
Can someone explain exactly how to do this for world of warcraft please!!! this is fuking up my day!
Reply Quote
37 Worgen Rogue
3555
Posts: 81
you guys are so awesome; i just had this command q happen to me on my mac while i was shapeshifting in my druid :D
I realized how annoying it would be to qq out of the game.
the directions were great

thanks so much!
Reply Quote
Amazing. Thank you so much. Did this for World of Warcraft and it works perfectly.

Machiavelli, to do it for Wow, follow the same steps, but instead of "Quit Diablo III" type "Quit World of Warcraft". When choosing the program, mouse over the WoW icon in your applications bar to make sure you choose the right application. In my case it was "World of Warcraft-64". Don't choose the launcher.
Reply Quote
Support Forum Agent
Posts: 14,784
I know in 1.0.5 PTR, the Command-Q in-game quit has been changed to Command-Option-Q. You can test it out there. We're planning the same change in World of Warcraft in a future update.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]