Diablo® III

FIX: Error 3007 (D-Link 615 router)

I was disconnecting every 15 minutes so I searched for a fix. I found the fix below relating to disconnecting from other games so I figured it would be worth a shot.

After I did this fix I was able to play for over 2 hours straight without any disconnects before I logged off for the night.

D-Link DIR-615 router - try setting UDP and TCP Endpoint Filtering to Endpoint Independent. Those two settings can be found under Advanced > Firewall Settings.

I would guess that many other routers have these firewall options as well. Perhaps it's worth a shot. Good luck!
Reply Quote
I use the : DIR-601 router and dont have these settings in that catagory =/ damn I need a fix, dcing every 20-30min sometimes more, opening ports did nothing.
Reply Quote
i have this router but i can't find the settings you mentioned
Reply Quote
Here are my exact specs for the DIR-615 I have:

Hardware Version: C1 Firmware Version: 3.13NA
Reply Quote
Posts: 7
Wonderful, it worked perfectly! Thanks for that!
Reply Quote
Awesome. Glad it helped someone else as well!! I've been playing without ANY disconnections for the entire day!
Reply Quote
This worked for me too :D! Thanks, Lega!
Reply Quote
Posts: 4
I have that exact router but not those settings in the firewall tab! Help?
Reply Quote
Posts: 228
how do you access these settings??
Reply Quote
Posts: 228
nvm worked it out
Reply Quote
I was disconnecting every 15 minutes so I searched for a fix. I found the fix below relating to disconnecting from other games so I figured it would be worth a shot.

After I did this fix I was able to play for over 2 hours straight without any disconnects before I logged off for the night.

D-Link DIR-615 router - try setting UDP and TCP Endpoint Filtering to Endpoint Independent. Those two settings can be found under Advanced > Firewall Settings.

I would guess that many other routers have these firewall options as well. Perhaps it's worth a shot. Good luck!


I have the DIR-615, changed the firewall stuff to independent, however, my firmware doesn't match yours and it says that it IS already upgraded?

Says mine is Hardware Version C1 - Firmware Version 3.11NA
Reply Quote
This worked for me too. thanks. blizz could add this to possible 3007 solutions.
Reply Quote
Worked for me after disabling SPI filtering on my modem as well.

Also created a POST with images incase some people dont understand how to do the above here:

https://us.battle.net/d3/en/forum/topic/5149178566
Reply Quote
90 Orc Warlock
9065
Posts: 15
Add me to the list that this worked for! Thanks!
Reply Quote
Worked for me too. Dir-615.
Reply Quote
I have a DIR-601. Found the same settings and applied them, but to no avail. I was still disconnected after 5 minutes. BUT, joining general chat still works for me. I just want to be able to leave general chat.
Reply Quote
90 Orc Warlock
9065
Posts: 15
scratch that, was working last night, getting 3007 again this morning
Reply Quote
This FIXED IT for me. Thank you very, very much. Most excellent.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]