Diablo® III

Diablo III Low FPS Fix

Hello Hello!

I'd just like to share a fix that worked for me regarding the low FPS. I'll try to be as detailed as possible. Hope this helps.

PROBLEM : FPS Drops to 5-20 during scenes with mobs, dirt, fire, water or anything else.

TESTED ON :

a. Alienware m11x R2 (Core i7, 8GB RAM, 500GB HDD, Nvidia GT335m, Window 7 64-bit)
b. Asus G73 (Core i7, 8GB RAM, 1TB HDD, Nvidia GT460m, Window 7 64-bit)
c. Custom PC (Core i7, 16GB RAM, 2TB HDD, Nvidia GTX 580, Window 7 64-bit)

SOLUTION :

1. Download Nvidia Driver 301.42 Driver
http://www.nvidia.com/object/notebook-win7-winvista-64bit-301.42-whql-driver.html

2. Go to Control Panel -> NVIDIA Control Panel

3. Under 3D Settings -> Manage 3D Settings -> Select a Program to Customize -> Find your Diablo III.exe

4. If you are using a laptop with NVIDIA Optimus, make sure you set the Preferred Graphics Processor to " HIGH Performance NVIDIA Processor". If you are using a NVIDIA card without Optimus just skip step 4.

5. Scroll down on "Settings for this Program" and set the following :
- Power Management Mode : Maximum Performance
- Maximum Pre-rendered Frames : 1
- Vertical-sync : Adaptive

6. Click "Apply" then close NVIDIA Control Panel.

7. Now go to Documents -> Diablo III -> Open "D3Prefs.txt"

8. Search for "HardwareClass" and change the value from "4" to "1".

9. Save D3Prefs.txt

10. Open Diablo III

11. Go to Options -> Video

12. Start everything on LOW settings for now.
Make sure you turn off V-SYNC, MAX FOREGROUND FPS and MAX BACKGROUND FPS.

13. Adjust slowly and see if you still get lags. I find it best to test it on Act III - Machines of War.

*No need to lower your affinity to 2 cores or set your screen to windowed mode.

I'm sure there are other fixes out there. It is odd that gaming rigs and laptops are having these FPS issues. Blizzard should address it as soon as possible. If they're gonna create a game after 12 years they better make darn sure it works flawlessly.

Thanks!
Edited by Plax#1704 on 5/24/2012 8:32 PM PDT
Reply Quote
Very nice and concise post.

I believe the "HardwareClass" setting is there in the prefs for a later date when Blizzard implement more graphics settings, similar to the 'Shaders' tab in SCII. Nothing wrong with manually adjusting it ourselves for the time being.

Unfortunately I still need to overclock my GPU to 900/1800/1600 (GTX560m 3gb) in order for a solid 60FPS game-wide (excluding heavy battles).
Edited by Headshaker#1717 on 5/24/2012 7:10 PM PDT
Reply Quote
Quick question, what does adjusting the hardware class actually do?

And personally, if I were to turn off vertical sync and have such high FPS caps, I'll be getting around 100+ FPS which ends up in screen tearing to occur.
Edited by Vindication#1940 on 5/24/2012 7:24 PM PDT
Reply Quote
For the screen tearing you can turn off your triple buffering. this should help the tearing some.
Reply Quote
i am gonna try this asap
Reply Quote
To the original Post.... Might want to add what windows version and "bit" tested on.
Reply Quote
90 Human Rogue
12150
Is this only for laptops?
Reply Quote
90 Human Rogue
12150
I'm on a PC, I didn't download the drivers, but I ran everything else. Took VSync off, but kept max foreground FPS to 60, so I don't fry my 570 HD graphics card. Runs like a dream now :)

Thank you!
Reply Quote
7. Now go to Documents -> Diablo III -> Open "D3Prefs.txt"

8. Search for "HardwareClass" and change the value from "4" to "1".

9. Save D3Prefs.txt


Your solution worked for me, but I didn't have to do the above steps to edit D3Prefs.txt. What does that do exactly?
Reply Quote
Didn't work for me either. :( I just want to play that's all.

Running a 540m here.
Reply Quote
-Might want to clarify that you are talking about specific NVIDIA card drivers.
-Core i7 doesn't mean anything. AT ALL.
Reply Quote
85 Night Elf Death Knight
0
Thanks for the help, I just don't understand why this happened over night. I was playing D3 just fine from the beta into the first 2 weeks, and then BOOM suddenly it gives me 4 fps? What happened?
Reply Quote
85 Blood Elf Paladin
4030
Only for laptop?
Reply Quote
The reason this works is it replaces Diablo 3's built-in vsync with NVIDIA's adaptive vsync in the driver.

Another solution for all cards is to use D3DOverrider -- download it (no install), add the Diablo 3 EXE, and choose Medium (vsync and triple buffering on).

Please add that to your original post, OP.
Reply Quote
Great information in this post!

For those of you with NVIDIA cards, there might be a more simple fix (it worked for me!) involving downloading a special set of drivers.

With my 1GB 9800GT, newest NVIDIA drivers, the game ran terrible. But the solution in this forum thread sealed the deal in 5 minutes flat!!

http://us.battle.net/d3/en/forum/topic/5149622996
Reply Quote
1. Download Nvidia Driver 301.42 Driver
http://www.nvidia.com/Download/index.aspx

2. Go to Control Panel -> NVIDIA Control Panel -> 3D Settings -> Manage 3D Settings -> Select a Program to Customize -> Find your "Diablo III.exe"

3. Scroll down on "Settings for this Program" and set the following :
- Power Management Mode : Maximum Performance
- Maximum Pre-rendered Frames : 1
- Vertical-sync : Adaptive


I also experienced huge framerate issues since updating to the new drivers. This fixed them completely on my GeForce GTX 460 SE, I didn't even need to bother w/ D3Prefs.txt.

Game runs better than ever now. Limited framerate to 70fps, it never drops below "59fps" now, even in big flashy battles on max settings. Thanks OP.
Edited by Nmaster64#1336 on 5/28/2012 6:23 PM PDT
Reply Quote
i cant find diablo 3 in the list by nvidia?
Reply Quote
So thank you Plax for your post. I ended up getting my Alienware m11x R3 from really inconsistent to buttery smooth by doing the following:

1) Following Plax's instructions. For me, this seems to have made some difference but step 2 really drove it home. I am not sure if it was a combination of both or what.

2) I was concerned that there was some generic Windows 7 power control CPU or GPU throttling going on. Control Panel -> System and Security -> Power Options. Select High Performance instead of Power Saver.
Reply Quote
Holy !@#$.
I thought I had tried every single thing that I possibly could...
I changed the settings that were listed, and the game now runs like a dream.
YOU ARE MY GOD!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]