Diablo® III

Diablo III Low FPS Fix

Posts: 62
Thanks for this info. I updated to the latest Nvidia driver 301.42, did a clean install in the custom installation options, and used the settings described by the OP. I am running at 60fps capped now with all settings on High at 1080 resolution, so it appears to have helped. Before I was capping out at 30 fps unless I set shadows and clutter density to OFF, and if I wanted to always stay at 60fps, I had to run at 1366 resolution.

The only downside is I am seeing some tearing due to the adaptive vSync, but it isn't that bad. I guess when it dips just slightly and runs at 55-59 FPS, it tears a little. I'm using Fraps (not recording) to see the FPS instead of the in-game counter (ctrl+r).

So, thanks for the information Plax! Seems to have helped me.
Reply Quote
Great info!

This advice has worked out really well for me.

I thought I had the optimus feature on my card (460m) but couldn't find the setting that you mentioned.

Now I am also experiencing the same vSync issue that Xplaced has mentioned but it's so much more manageable to deal with that rather than trying to enjoy the game with the lousy fps I was getting.

I was another disappointed g73 owner up until 15 minutes ago. TY!
Reply Quote
I've tried all of this on my alienware m17x r1 w/ 2x 260m gtx's to no avail. Here's a link to my post: http://us.battle.net/d3/en/forum/topic/5596251805

I should be able to run this game with ease :\
Reply Quote
I appreciate the concise post, and I will give this a shot. But my eyes already glazed over at Hardware 1. This makes the Shadows look like dirt and removes some critical graphic elements from the game.
Reply Quote
For everyone who downloaded the new nvidia 301,42 drivers and got crazy fps issues. There is a known issue with overclocked graphic cards in the 300 driver series.
Best you can do is to either lower your clock to original value of your model or get a driver version under the 300 series, like the 296,10 one and it will run smooth again.

Nvidia are aware of this and quote "We were able to reproduce the 3D clocks issue and have rooted the cause. Schedule fix in next driver release."
Reply Quote
Honestly, I was 1 forum search away from getting up and going and buying a new graphics card. I had my doubts that this would work but I tried it as my very last resort. I've been playing for 2 hours straight now without any lag or FPS degradation. This definitely worked for me and I thank you Plax for posting this fix. This needs to be stickied by the forum administrator for those of us who use GeForce 9800's.
Reply Quote
I just wanted to add something, I didnt do any of those steps EXCEPT the change of hardware class from 4 to 1.. and it completly fixed my slow motion problem, thanks a lot!

(Not using a laptop, just a pc with an Ati card)
Reply Quote
560Ti here, this didn't do anything for me. Still at 10 FPS regardless of low/high settings in the game.
Reply Quote
Posts: 217
What about ATI?
Reply Quote
Posts: 82
Dear OP, You saved me from suicide. I am in your debt.
Reply Quote
GTS 250, doesn't work for me =/
Reply Quote
I didn't have any issues until 1.0.2b I think, now I have the same stuttering everyone else is. I tried this and it didn't work, unfortunately.

System Specs:
Intel Core i7-2630QM CPU @ 2.00GHz
GeForce GTX 560M
Windows 7 64-bit
Reply Quote
Plax you are the forum hero u bravo man gd job you must work with blizz the game run on my asus GT540 like the bullet thnx very much
Reply Quote
Hey guys.
Really nice thread! I followed every step and it worked, not entirely though. At first, I used to have frame issues since the start of the game and a lot actually. Now the game runs perfect (60 fps) for the first 10-15 minutes regardless the area or the number of mobs. The thing is that after that time, my fps drops to 35-40 and on fights I get 10-20 while my graphics card reaches 95 degrees, plus it doesn't get better even if I switch everything on low/off.
Is there any solution to that?
I m using laptop with i7 2670QM @ 2.20 ghz, SLI nvidia gtx 560M (would it help if I tried to turn on the SLI?), 8gb ram, windows 7 64-bit.
Reply Quote
101 Human Warrior
Posts: 7
+1 internets to you, my friend. I can play again! ^_^
Reply Quote
Reply Quote
these settings on 304.48 do not help fyi.

Lesson to be learned here is Nvidia cannot make a driver worth a lick. The drivers for the whole GTX 460m serious are terrible. All my games run like crap. Next card is ATI all the way.
Reply Quote
oh my god! finally its work!!!!!!!!!!! thanks you u r my save!!!!! !@#$%^-it its fixed! thanks you thank you!!!!! no more shutter!!!!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Explain (256 characters max)