Diablo® III

ingame lag or something

when i type in my password to log in to diablo 3, the characters are late by 1 second, if i move my mouse over something, it takes a second to light up and when i take the mouse off that same thing it takes a second for it to become darker.

also the biggest problem is when im playing, i would click on a place to go and it would take about a second for him to respond and move there, and combat is horrible i would fight monsters and they would "teleport" i no zombies cant do that so there is clearly something wrong

SOMEONE PLEASE HELP ME
Reply Quote
90 Human Death Knight
8690
Another average day in the realm of Sanctuary.
Reply Quote
85 Blood Elf Paladin
1810
I was having the same issue, Stew. Using a Radeon HD4550, it seems to be an issue with ATI cards from what I've gathered from the forums.

Try setting your resolution a step down from the proper resolution (IE 1680x1050 becomes 1440x900). It doesn't completely fix the slow gameplay and teleporting mobs, but for me at least it GREATLY lessened the severity of the issue, allowing me to actually play the game.

Hopefully there's more news from Blizz on the issue with ATI cards, and a fix incoming.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]