Diablo® III

Continuous Lagging Issues with Diablo 3.

I'm a little worried that i wont be able to play diablo 3 at all, my internet connection is not exactly the fastest connection out there and it seems every time i play the game i lag and by lag i mean it jumps all over the screen and my attacks respond about 40 seconds later than it should, i cant access doors and talk to in game characters, so yes it lags a lot! so much that it makes me turn the game off in frustration.

I am just wondering if there will be a fix for this or if Blizzard will be putting up a Server for Australian Users? so that i can enjoy my game.

P.s on another note i don't really care about the whole online side of things, i just wanna be able to play the game and not have to worry about a continual online connection, i wish they would maybe make an offline mode? hmm
Reply Quote
Yea me 2 i was in a party with a demon hunter and his latency was 70 and mine was 145 and i still was having so much lagg i couldnt even hit things i am on a mac book pro and i have a great internet connection wow runs seamlessly , starcraft runs seamlessly. its a newer mac bok pro everything should run good on it but no... wtf blizzard wtf
Reply Quote
Same problem here in New Zealand:( Each attack happens typically 5 seconds after I press the mouse button which means by the time I see the effect of my attack I'm already surrounded by enemies and my HP has dropped a quarter....

Why can't there be an offline mode? Isn't that what single player game is all about?
Reply Quote
Same issue, have logged a docket for it. The lag is freezing my game every 30 seonds for minutes at a time. I need an offline mode or access to servers that work. I don't have this problem with other games.
Reply Quote
yes that is exactly what a single player game is about, its about time for you and your gaming rig to bond without the interruptions of a seemingly online universe.

I'm happy just to play the game in Single Player and have no Multi Player options.
Reply Quote
That's unfortunate. I was getting ping of 400-800ms earlier, before the maintenance (but even that's nowhere near as bad as you're describing) but now I seem to get a steady 100-200ms.

Sorry I can't help, I have no idea what would be causing it : (
Reply Quote
well here is hoping that Blizzard listen to the Aussies and New Zealanders and establish a server dedicated to us, because im sure there's hundreds of thousands of us that will want to play it smoothly.

but seriously lets just get an offline mode:)
(it could just be me who has a shocker of a connection to create such lag)
Reply Quote
also curiously how do i check what my ping is running at?
Reply Quote
now I seem to get a steady 100-200ms. (


How can someone from Aus/NZ get 100ms to a USA server? That's physically impossible.
Reply Quote
Mine just says 0 ping, and after about 20 seconds i get dc'd, WoW runs fine youtube loads fine ventrilo works fine, its just my diablo, my friends are fine on it idk wtf it is but man it is annoying, this morning and up to 5:30pm AEST it was fine, then i left, came back and its not 7:58 and i cant play at all, i wish they could just get their servers right. but i bought the disc and my friends downloaded it, idk if that will affect it but yeah, let me know if anyone else downloaded it and still has these lag issues
Reply Quote
ive been playing all day and just in ther last 30 i have been lagging out of every game and its really starting to annoy me youtube loads quick so its not my internet
Reply Quote
Sorry to burst your bubble with hopes about offline play, but it will never happen.

http://us.battle.net/d3/en/forum/topic/5149175409
Reply Quote
BumP!!! Exactly the same problem. It's not a latency issue. It's some sort of bug. 5 second delay to attack.
Reply Quote
I'm in America currently having this issue. I'll be playing with friends and my latency will be fine, then out of nowhere I'll have a gigantic lag spike. I'm talking Herculean lag. I completely missed out on the entire fight with a boss because of this issue. For me, we all just stood around. About three minutes later, there was a fury of movement on my screen and sound, then there was loot and I was dead. It's not a rare occurrence and it's making it incredibly difficult to enjoy the game.
Reply Quote
05/16/2012 03:17 AMPosted by Ash
BumP!!! Exactly the same problem. It's not a latency issue. It's some sort of bug. 5 second delay to attack.
5 second... atleast you can play then i cant even talk to anyone, i load then stand there for a few secs then dc, and its not my net, my friend can play my account fine, so i am going to get it off him as he downloaded it and try that otherwise diablo is the 'best'
Reply Quote
Yeah man, im from NZ aswell and i'm pretty much having the same problem as you, my attacks take about 3 seconds to complete and the lag is really bad for me , Blizzard FIXS IT!!!
Reply Quote
Aus east coast. Playing on Asia server. Terrible lag all the time. It's killing my enjoyment of this game
Reply Quote
I'm getting ridiculous lag with downloaded version
Reply Quote
I get greater than 1000ms ping after play time of about 2 hours
Reply Quote
90 Night Elf Druid
3740
Same here. Could this please be addressed by someone at Blizzard before it turns into an issue for the Australian Consumer Complaints Commission? Supplying a product and then denying or limiting use of that product is a breach of consumer rights, apparently. That being said, I don't want a refund, I just want to be able to play!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]