Diablo® III

Severe performance drop from open beta

90 Night Elf Druid
0
Hi all, when I played the game in open beta the graphics were amazing and fluid and held at a solid 60+ FPS. Now once I managed to get in after release I've discovered a severe performance drop, the framerates are very stuttery and responses are much slower. It almost seems like the game is running thru molasses. I turned down the graphics settings as low as I could and it helped marginally but the performance level is nowhere near the quality it was during the open beta on maximum settings. Is anyone familiar with this issue and is there anything I can do to fix it, or is it a problem with the game itself? I know it's not my laptop's fault, it runs much more graphically intense games without a problem and like I said during the open beta the performance was flawless. Thanks to all who read this and I appreciate any advice!
Reply Quote
85 Tauren Priest
1820
Same here, the beta played great. Now it's unplayable, just like WOW.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]