Diablo® III

Screen Tearing with VSYNC on

Has anyone else experienced this issue?

For some inexplicable reason, I'm now getting screen tearing across the middle of my screen when playing Diablo 3. It's almost like I have VSYNC off, except that it stays in the same horizontal line constantly - it might move slightly up and down the screen, but it's always right across my character. I've used FRAPS to confirm that VSYNC is working, I get a constant 60 frames per second that doesn't fluctuate.

I've tried turning VSYNC on/off and played with the max frames per second option (even though it shouldn't really affect this). I'm using a GeForce GTX 570 with latest drivers (296.10) and I didn't have this issue until today. Rather baffled at the moment, was just wondering if anyone else has seen this?

Cheers.
Reply Quote
I can confirm this issue, setting vsync forced through driver settings did not aid nor did installing any earlier or later driver.

GTX 580 with 296.10.
Edited by Mathizsias#2592 on 5/19/2012 9:15 AM PDT
Reply Quote
Same thing for me, 560 Ti with the 302.59 Beta drivers, and I tried the 301.40 drivers. Could not force Vsync and triple buffering through Control panel.
Reply Quote
Thanks for the feedback, glad to know it's not just me.

I have found a workaround, if you change the Display option to "Fullscreen Windowed" in the options it stops the tearing. Makes my GPU work considerably harder, but it does get rid of that awful tear across the middle of the screen.

Cheers.
Reply Quote
blizz, fix this. I do not want to play my game in "Fullscreen Windowed" mode.... any other workarounds?
Reply Quote
I experience this annoying screen tearing as well with my gtx260². Switching to "Fullscreen Windowed" doesn't change anything. Sometimes i get the feeling that all the people around me can't see tearing effects in games at all. Thanks for approving my observation guys. I felt close to ge nuts.

@Blizzard: Pls fix this!
Reply Quote
I see this very rarely.

G73 Laptop
i7
Radeon 5870M
8GB Ram
Running D3 off Intel 520 SSD

Seems to happen mostly when I first start a game.
Reply Quote
bump. vsync has major issues that need to be addressed.
Reply Quote
Lot of games has tearing even with VSync on. I have found out that RivaTuner can help. You can force set VSYNC on with it.

For me, I can't actually tell if Diablo is tearing or only stuttering. VSync setting doesn't do anything.
Edited by pahuttun#1879 on 5/22/2012 2:32 PM PDT
Reply Quote
Worse performance with VSync on in general. Have no such issue with other games, though. Conclusion? You name it.
Reply Quote
It's part of the stuttering issue. I have the same issue. It's like the game just doesn't care what your settings are. It's like the game is going to run crappy and under full gpu load regardless of what you do.

The only thing that seems to work over multiple reboots of the game and my pc is setting my gpu to balanced in the control panel. There is still some stuttering and some fps spikes, and drops, and the gpu is still under full load on the lowest setting in the game, but it is at least playable.
Reply Quote
Hello. I had the screen tearing problem too with my nvidia 560 Ti video card. I managed to solve this problem after enabling vertical sync in the nvidia control panel. You can find it by right clicking on your desktop and selecting “nvidia control panel“ in the menu. You can also find it by pressing start -> control panel -> nvidia control panel. In the window that opens go to “Manage 3D settings“. When there, in the “Global Settings“ panel you will find “Vertical sync“ at the bottom of scrollable list. By clicking on it you will see 3 choices. “Use the 3D application setting“ is what I am using right now to play without screen tearing, but “Force on“ has also solved the problem for me.

If your video card is a radeon, there is a hot fix in the technical support thread on the forums. If that does not help, maybe there is something similar to the nvidia control panel for radeon video cards as well and you will be able to change the settings of your card there (not sure about this thou). Good luck.
Reply Quote
I believe the issue most people are seeing here is related to the bug in blizzards "Fullscreen" display mode. After several days of testing, it appears that it has a hard time working with directx settings via the nvidia control panel. Case in point, the fact that it doesn't honor vertical sync set externally, and has some major screen tearing and stuttering performance issues, despite a favorable FPS rate.

And similar to what someone above alluded to, the "work around" is to set the display to "Fullscreen Windowed". You aren't going to see any windows border, but it will be running as a window. Now this may not be desirable for everyone, but it does get rid of the problem. Immediately. And it gets you back to playing. I was able to customize my settings in nvidia control panel again, frame rates stabilized.

Suggested settings being:

Diablo 3
Max foreground: 60fps (this removes the skittering text and labels)
Max background: 60fps (can be lowered if needed)
Vertical sync: Off

nvidia control panel
VSync: Adaptive (latest drivers should contain this option)
Negative LOD bias:Allow
Triple buffering: On

Everything else you can customize to your own taste.

I'm running a GTX560.
Reply Quote
I had same problem. And it was, that I had turned on duplicate screen (when you press win + p) I believe it's only when you have two monitors, or tv and monitor (my case).

So I set computer only, and it's ok now.
Reply Quote
Thanks HugeGuy, this seems to have worked for me. Only been playing for a few minutes since I changed all the stuff but I haven't noticed anymore problems
Reply Quote
Well I have the same problem and the settings suggested in the other replies had no effect.

I'm running a GTX680 with driver 320.18 (though I have tried every other driver from 308 to the beta 349) and I'm getting constant screen tearing either right above or right below my character.

I'm also getting lag in 4 player fights even though this pc is just 2 months old. Shouldnt be happening with the hardware I'm running now.

Any other suggestions?
Reply Quote
Well I have the same problem and the settings suggested in the other replies had no effect.

I'm running a GTX680 with driver 320.18 (though I have tried every other driver from 308 to the beta 349) and I'm getting constant screen tearing either right above or right below my character.

I'm also getting lag in 4 player fights even though this pc is just 2 months old. Shouldnt be happening with the hardware I'm running now.

Any other suggestions?


try Windowed (Fullscreen) mode
Reply Quote
Tried it, makes little difference.

I'm starting to think my video card may be broken though.
Reply Quote
I'm having this issue as well. Screen tearing with vSync enabled.

GTX 680 with 331.82 drivers
Reply Quote
I know what you're describing. You actually would probably get this line intermittently in all games, but you just happen to play D3 more and thus you've only seen it in D3. What's happening is windows isn't tracking time quite right, and thus frames get delivered consistently a hair early or a hair late.

Here's what fixed it for me:

1. Enable HPET in BIOS. If you have HPET option in BIOS then your hardware can support HPET. If your BIOS doesn't have this option it's probably on no matter what.

2. Enable HPET in Windows by giving this command in admin credential CMD:
bcdedit /set useplatformclock true

3. Reboot

source: http://www.neowin.net/forum/topic/1075781-tweak-enable-hpet-in-bios-and-os-for-better-performance-and-fps/

By the way if you have win8 you're SOL. It doesn't support HPET.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]