Diablo® III

Teleport Bug

Posts: 1,652
Sometimes when this skill comes off cooldown, it teleports you back to where you were when you landed from the teleport. Also, I got stuck in an area once after this happened, and couldn't move or attack, but I teleported out of it after the next cooldown cycle. I'm using Wormhole for my rune, obviously (the only useful one).
Reply Quote
same problem with wormhole here, im using it on my mouse wheel. It happens randomly while im playing, i tryed unsuccessfully to recreate it at town...
Reply Quote
100 Worgen Druid
16215
Posts: 511
Posting as confirmation. Teleport will periodically fire off on its own.
Reply Quote
90 Goblin Mage
0
Posts: 89
Confirming this as well, Teleport randomly activates, sending me back to where I was about 10 seconds ago. Using the Wormhole rune. This is most noticeable when running back after dying.
Reply Quote
I'm not quite sure if what happened to me today is the same thing but...

I safely teleported away from mobs, standard mobs.. no champion packs in sight. The second I landed at the safe spot I warped back to where I came from and died from a melee hit.

This happened twice in one game, multiplayer, on my way to the butcher.. level 3 I think.

I am using the Fracture rune.
Reply Quote
90 Undead Warlock
9655
Posts: 1
Also getting this problem with the wormhole rune.

When the teleport cooldown ends, i am teleported to the last teleport location. Annoying when it is back to the start of a dungeon.

This has been happning when i am spaming the teleport key - to get as many teleports as possible. My ping is 300ms, this effects how many teleports i get. Unsure if its related to the problem.

Holding down the teleport key has yet to do this to me. (Could just be luck).
Reply Quote
Methods I've been able to recreate this/notes about the problem:

Wormhole: if you "cast" teleport as the worm hole CD is ending and get the animation of casting, but do not move, once teleport is available it will fire off sending you backwards. This problem is worsened with the passive [Illusionist] since if you're struck and the teleport skill resets it sends you sailing back into the mob you just escaped.

Illusionist: even without wormhole I've had this proc and send me backwards a few times, however much less common without wormhole than with it.
Reply Quote
Just coming on to post his bug myself. Wormhole rune. CD is spent and I'm sent back to the last place I used teleport. Sometimes this happens when I'm spamming the ability as it comes off CD, sometimes it happens when I'm not trying to use it at all.

Overall though, I've noticed on different classes that my location will revert back to one previous. I think the overall problem might be related to this, Teleport just makes the problem significantly more noticeable.
Reply Quote
this might just be internet / computer issues
i use wormhole tons and i never get that problem
i do get the tele auto fire issue but only a couple times while i was in town
Reply Quote
Methods I've been able to recreate this/notes about the problem:

Wormhole: if you "cast" teleport as the worm hole CD is ending and get the animation of casting, but do not move, once teleport is available it will fire off sending you backwards. This problem is worsened with the passive [Illusionist] since if you're struck and the teleport skill resets it sends you sailing back into the mob you just escaped.

Illusionist: even without wormhole I've had this proc and send me backwards a few times, however much less common without wormhole than with it.


Thanks for the clarification. I've experienced it as well. This is obviously related to programming based on the "reversal" rune for teleport.

My theory:

I imagine some code logic like:

If teleport is cast following teleport cooldown start but before cooldown finish, warp the player back to the position of their last teleport starting point. (makes reversal work)

In the explanation you give, it sounds like it reads the teleport cast as having occurred after the teleport cooldown start, which is why you get the animation but no movement. Next teleport, it is deciding where to move you and the code might be very roughly similar to:

start loop

Is teleport animation finished?

>YES >Activate teleport

>NO > Start animation & wait until it's done

Loop

Since you finished the animation already, you teleport immediately. Since you teleport before it would normally be possible (no waiting for animation), it thinks your teleport occurred during the cooldown and therefore must have been a "reversal" teleport.

So question that would help test this: when this bug happens, does it properly display the full teleport animation before you teleport, or not?
Edited by Zeromus#1415 on 6/4/2012 2:09 PM PDT
Reply Quote
Posts: 9
05/26/2012 07:51 PMPosted by Vidaria
Posting as confirmation. Teleport will periodically fire off on its own.


This has been my experience as well. +1 Confirmation
Reply Quote
Posts: 65
This is an example of what happens, in my experience.

This were all done in quick succession:

Press the button once: First teleport succesful.

Press the button a second time: Second teleport succesful.

Press the button a third time: Third teleport unsuccesful, skill on cooldown.

Skill comes off cooldown, immediately teleports me to the position I was supposed to land on the third cast, regardless of where I'm currently on the map.

To me, it seems that with the wormhole rune, it checks whether or not the skill is on cooldown mid script, or after running an iteration or finishing to run the entire thing. So if it's on cooldown, it doesn't teleport you immediately, but still does it as soon as it goes off cooldown.
Reply Quote
+1 Confirmation
Happens when I'm trying to speed clear an act or dungeon
Reply Quote
100 Worgen Warrior
20460
Posts: 4,783
http://i.imgur.com/t8X07.jpg

Here's a picture to help a bit =D

I was trying to kite a pack of champions that I couldn't kill around the red mark. I start spamming teleport (wormhole rune) and near the end of that second it ports me back to the yellow circle.
Reply Quote
90 Troll Mage
12575
Posts: 24
+1
Happened to me aswell, several times actually. And the mostly annoying ones during Inferno Azmodan Pool Phase... It just teleports me right into the middle of a Pool when it happens.

And BTW, It also happens with Teleport - Fracture (+ Passive Illusionist, The one I am using most of the time in Inferno).
I am guessing that this can happen with any Teleport rune (or no Rune at all). It also happens with Demon Hunter's VAULT, Exactly the same thing. (I Play both, Wizard and Demon Hunter)

Blizzard, Fix this. Seriously. It's annoying as Hell (or Should I say Inferno? lol)

PS: I play with a constant 200ms most of the times, and 400ms when servers are "laggy", lag should be no reason for it to Bug, and even if it was, It SHOULN'T HAPPEN - period - since I CANNOT PLAY OFFLINE, and there is no reason for a Skill to not work properly due to latency.
Edited by Skyrius#1666 on 6/11/2012 8:50 PM PDT
Reply Quote
I posted this in another bug report before I saw this one.

I have come across the same issue. After casting the first two teleports and attempting to cast the third, the character will do the spell cast animation, but the spell will not work. Seems to happen if the teleport is cast as the cool down initiates. As soon as the cool down finishes, the spell takes effect and the caster is teleported and the cool down begins again. I've had all of the following scenarios occur with the third teleport:

1) Nothing happens (I saw the third cast animation, but when the cool down finished, nothing happened, and cool down did not initiate)
2) Teleports ahead as if I had just cast teleport
3) Teleports for zero distance
4) Teleports backwards as if I had just cast teleport
5) Teleports and puts me where I would have been if the third teleport had actually cast correctly
6) Teleports backwards some X amount. I've gone many different distances on this one, but never further than where I would have been if the third teleport had cast correctly.

Edited for clarity.
Edited by Slicktrick#1997 on 6/12/2012 1:18 PM PDT
Reply Quote
I discovered a work around:

If you are spamming the button assigned to your teleport skill and want to make sure that it doesn't re-teleport you when the cool down finishes, just cast another spell while the cool down is still going. I've tested this a number of times (under safe conditions since I play HC) and it has consistently worked for me.

Again, the tell-tale sign is that you character will do the teleport animation without actually teleporting. You are guaranteed to teleport as soon as the cool down finishes in this case (usually back to where it was originally cast). So, use this work around for now to prevent the teleport from mis-firing.
Reply Quote
New issue with it. I teleported backward to where I had cast the third teleport, and then could not move. No matter where I clicked, my character was stuck in their spot.

Teleport plus wormhole rune.
Reply Quote
Posts: 63
Wormhole, this happens to me too.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]