Diablo® III

Gforce GTS250 Black screen (Solution!)

100 Pandaren Warrior
12685
Posts: 420
For anyone who's seen this issue before... its annoying as hell and makes the game nigh unplayable at times. For those that don't know here is a brief overview of the problem.

*D3 goes black screen for 2-5 second periods every so often, the frequency is random, could be 5 times in a few minutes or once in a 4 hour play period.
*D3 black screen "Alt-tabs" the game, then upon resuming tanks the FPS from 150, to 9, making the game lag horribly and makes it unplayable.
* this effects anyone with a Gforce GTS250 video card. I know some other cards are having the issue just not sure which ones specifically as this is the card I run and have noticed most frequently mentioned.

Solution!

For some the solution was easy for others it was difficult, I personally had to do 3 different things to make my game stable and run smoothly.

*Set my game resolution to 1280X720 (16:9)
*Cap my FPS at 70, background FPS at 8
*Download the Nvidia Control Panel from Nvidia's website, (google works too) once installed Look at the menu list on the left side of the program, go to Performance then Device Settings. Once here click on the Custom button just above the Clock Mhz value sliders.
Customize each slider down by 50Mhz, apply and save these settings.

Open D3 and run as normal, yes the game will look more pixilated from a lower rez and might run slightly (very) slower due to a lower clock speed, but its the only thing I've found so far that works for a solution.

I personally had to do all 3 of these to get mine working, but I've heard of some folks only needing to do one or two of them to have the same effect. Also as noted by blizzard make sure you have your beta client uninstalled to be on the safe side.

Using this method I played half my day yesterday without any interruption.

Best of luck and hope this helps!

~Tera~
Edited by Teradel#1795 on 5/17/2012 9:04 AM PDT
Reply Quote
100 Pandaren Warrior
12685
Posts: 420
Bumping for anyone who needs to see this.
Reply Quote
Just doing the underclocking seems to have resolved it for me.

Thanks man! :)
Reply Quote
100 Pandaren Warrior
12685
Posts: 420
Yeah underclocking for me solved the random black screens but not the alt-tab problem, had to alter my framerate and resolution for that part of it ><
Reply Quote
100 Pandaren Warrior
12685
Posts: 420
Bumping this one more time as people need to see it, before i head off for a nap, hope it helps someone!
Reply Quote
Posts: 3
Thanks Terdel, It worked for me, in fact underclocking seems to have increased my performance! Go figure....

I only turned up the fan speed to 80% and downed each clock by 50.

Thanks again
Reply Quote
100 Pandaren Warrior
12685
Posts: 420
No problem, glad to help :)
Reply Quote
85 Human Paladin
10710
Posts: 73
Most people having this problem are using Windows 7 64 bit, and the solution other than what you described has been to turn off windows aero, or go to my computer, right click. properties -> Advanced system settings -> Settings -> Adjust for best performance (which turns off windows Aero (desktop composition) the thing that allows you to preview another window on the taskbar.

I did what i described and it's worked for me so far. If i have problems I might try your fix. but mine is working good now
Reply Quote
Thanks for posting this!

I've only done the underclocking bit. After that the game would run nicely and then randomly drop to 9 FPS and I'd had to restart my pc.

Will add the other solutions to the mix.

Sad that users have more answers than Blizzard.

Thanks again.
Reply Quote
85 Blood Elf Mage
4145
Posts: 37
I'm using GT335 2 years old computer, and I have this issue too
Reply Quote
100 Pandaren Warrior
12685
Posts: 420
Good morning!, bumping the post as its been useful to quite a few so far, spread the knowledge!
Reply Quote
Posts: 8
Wow I didn't realize this issue was specific to the GTS250,

I've been trying a bunch of other solutions posted in similar threads.

Just did the underclock thing a couple hours ago and played with no black screens for a couple hours (was getting them every 5-10 minutes).

Will try some more later, but seems to be working. Thanks Teradel!
Reply Quote
Thank you so much for this. Bliz is watching us enough to put in a hot fix to stop Athene's technique (on his quest for first 60 on Inferno), yet they don't comment on the many of us having an issue just trying to play their game. :(

Thanks again Teradel. Hope this works, but I'm put off enough by the black screen to try playing any more tonight. I'll make the changes and see how it goes tomorrow.

EDIT: I am so completely frustrated right now. I have a version of Nvidia control panel, but it doesn't have any options like you mentioned. I can't find anywhere on their site to download it, other than drivers (not sure if it comes in the driver download or not). I found screens shots of what it sounds like you are describing, but for whatever reason mine is not like that, and I can't find a way to download it. I updated my drivers and the panel is still the same.

GeForce GTS 250
Edited by Warwall#1217 on 5/18/2012 9:43 PM PDT
Reply Quote
Posts: 8
This is what I downloaded Warwall, couldn't find anything else, but I had the same hang-up until I downloaded this:

http://www.nvidia.com/object/nvidia-system-tools-6.08-driver.html
Reply Quote
This is what I downloaded Warwall, couldn't find anything else, but I had the same hang-up until I downloaded this:

http://www.nvidia.com/object/nvidia-system-tools-6.08-driver.html


Thank you. I think I did download that this morning before checking back here, and I now have a performance options, but still have have the options listed within that. I'm going to DL from the link you gave though.

Edit: I had to accept the end user agreement from with in the program itself, listed under performance. I now have the options. :D Hope this works, I want to get some solid play in after work tonight.

Edit 2: I bumped all the MHz do by about 50, and ran the game in full (wide) screen and played about an hour with no black screen. :D Hope it will be good to go from now on.
Edited by Warwall#1217 on 5/19/2012 8:05 PM PDT
Reply Quote
Yeah it slightly worked for me as well, went from black screens every 5 minutes to it letting me play a full 2 hours before getting one, Now its frequent again, and thats after lowering each speed by 150, I'm running a Geforce 9800 GTX+ btw, so no it isn't dependant to just the 250 cards.
Reply Quote
Peeps think blizz is ignoring this issue but Blizzard actually pointed me to this thread:)

still not a fix of the main issue, to have to underclock my mediocre card to play just doesn't seem right
Reply Quote
I have experienced the same problem with Geforce GTS250 when playing Diablo III, mark this post first and will try it 2nite.

Will update my result later

Thanks

Update: now i dont hv the black screen every few mins or suddenly bounce back to windows desktop screen, lowered everything by 50 then works perfectly. Awesome.

Thanks heaps, Teradel !!!
Edited by KelliEBrO#6169 on 5/21/2012 6:01 AM PDT
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]