Diablo® III

Gforce GTS250 Black screen (Solution!)

06/23/2012 05:56 PMPosted by Morderischen
Wait but if I underclock my card will i have problems in other games? It doesn't seem like a very good solution if you intend to play other stuff right?


Agreed, Underclocking isn't really a solution, unless all you play is D3.
I'm using a GTS250 as well. Now, I've seen others post about the black screen every 5-10 minutes...well I don't have that issue. I'm using the current up-to-date Nvidia Drivers and only have these problems when dealing with my stash.

I'm going to check Guru3d for different Nvidia drivers..
Reply Quote
86 Human Paladin
5555
Posts: 3
Do you need to change

Cooling

Voltages

or

Device Rules at all too?
Reply Quote
86 Human Paladin
5555
Posts: 3
Thanks Terdel, It worked for me, in fact underclocking seems to have increased my performance! Go figure....

I only turned up the fan speed to 80% and downed each clock by 50.

Thanks again


Mine is at 5% I think. Do you mean you manually changed it to 80%?
Reply Quote
Posts: 18
Bumping, this worked with me.
Reply Quote
oh my I need to try this I have a 250 as well, I will try this tonight!

Thanks!
Reply Quote
Hi all! Pls help! i have Ati Radeon HD 6670..starting Diablo 3...and total black screen! any fix?
Reply Quote
Got gt320 i also have the black screen.. can find the clock sliders on the control panel for my gpu..
Reply Quote
GTS 250 - Same problem on my brother's computer. It complete fixes it. thanks.
Reply Quote
Hey guys. That's what I did and Worked. Try this instead of lowing your graphics in the game, what is just bad to do...
I have a GTS 250 too and started with a lot of problems in black screen and video driver stoping issues.
What I just did was go to > Battle.net instalation folder > rigth click on the Battle.net.exe > Properties > Compatibility > and then check: disable visual themes and disable desktop composition.
This disable the aero when you start the battle net.
Im running all on full and have no need to disable the good graphics of Diablo 3. Hugs and hope it helps!!!
Reply Quote
Hello all :

The good way to solve your problem is to downgrade your driver : that's the only way I found.

so First uninstall you drivers from ad/remove programs in control pannel
Restart your PC
And install the downloaded driver then.

This link gives you the good driver you have to use :

Win 7 32bit :
http://www.nvidia.com/object/win7-winvista-32bit-266.58-whql-driver.html

Win 7 64 bit :
http://www.nvidia.com/object/win7-winvista-64bit-266.58-whql-driver.html

It works for me so enjoy !!!
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]