Diablo® III

Solved - Display driver stopped responding

Solved - Well for me anyway

Display driver amdkmdap stopped responding. - Notebooks and Laptops

I have been doing a lot of reading and research about this issue. I read on a thread somewhere (I cannot find it again but thanks to the posters) that this can be solved by under clocking your graphics card slightly. Then about 1 hour later it clicked. For me the problem was the power plan I was on in Windows 7. It was on performance and I changed it to balanced. I was always crashing at least once every 5 minutes and especially in the cathedral. The screen would go dark and then windows would recover the display driver.

I had tried everything from driver sweeper, rolling back graphics card drivers and also installing the latest of everything. Even editing registry to change TDR settings. I also tried uninstalling the C++ redistrib's. NOTHING worked at all. Until I did this.

I hope this helps someone and saves them more time than I wasted trying to get this game to work.
Edited by Hejeminey#6144 on 5/20/2012 3:41 AM PDT
Reply Quote
Has this worked for anyone else?
Reply Quote
mine cracks out when my computer is plugged in
Reply Quote
That is the power options will be set to go to preformance mode when you have power and then battery saving mode while it is unplugged.

Change your power plan to always balanced and then reply on this forum when it works
Reply Quote
Posts: 22
Ok, if indeed the windows power management setting affects this, then let's analyze this.. What setting would it be?

Could it be the PCI express link state power management setting in advanced? It has to be one or 2 particular's here...
Reply Quote
Posts: 39
I think what happen is that when you change the power management settings to balanced, you are pushing less juice to the video card, which reduce heat.
I did have my laptop (asus g73) blacked out twice on me, I have to turn it off, wait for a bit, then turn it back on.
If you turn your video settings down a bit, it will also helps, since it will requires less power, which means less heat.
Yes, just because your GPU is capable, it will still overheat, hence why all the video cards nowadays (compare to 10 years ago) all have a cooling fan on it.
If you still want max performance, try purchasing a cooling pad, if that still doesn't work, you will have to take your laptop apart and install custom cooling parts.
Edited by Stealth#1502 on 5/22/2012 5:17 PM PDT
Reply Quote
Posts: 22
Interesting.. you all know this is also happening on desktops right? In this thread..
https://eu.battle.net/d3/en/forum/topic/4078547824?page=6#108

I can see this with a laptop perhaps. But I'm not convinced windows power management actually alters the power going to the GPU. Compare each setting and the answer will lie in one likely..
Reply Quote
I ran GPU temp monitoring software and it did not go over 80 deg C even with all the setting s on max. I tried to lower every setting and this did not change the crashing. It looks like from the other forums there is an issue with diablo whenever gpus are over clocked and I think the power management on performance does this to some degree. It is the only thing that worked for me and I have tested it as well by changing back and it crashes again.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]