Diablo® III

Display driver stopped responding... -Fixed!

*updated - next I need to text cranking up some of the CCC setttings, and lastly go back to OC'ing the card, but I just played for 2 hours with so much as a hiccup. I can say this procedure is a fix for my D3 causing the "Display driver stopped responding and has recovered" frequent crashes.
_____
I spent the last 2 days trying to resolve my “display driver has stopped responding” error that keeps happening in D3. I’ve seen several posts spotted around the web that lot of people are having this issue, regardless of AMD/NV cards. Wanted to share what I went through and hopefully what resolved it so the game is stable. If you have any questions I'll try to answer them best I can.

Background Details:
AMD 7750 - Overdrive turned on and maxed - Catalyst settings turned on - Win 7x64
D3 Beta I had no graphics issues/crashes
Catalyst drivers tested: 12.4, 12.4a, 12.5beta. All had same display driver failure
All graphics settings tuned/turned down in Diablo - no improvement
FPS limiting tested at 200-150-100-75-60-55-30-15 - no improvement
Tried going MS-config, turn off all startup devices - Could not load Diablo 3 (shows running in task manager, never comes up)
Failures still occurred on clean created user profile, same as regular profile (win7) under all configs above
Windowed mode of various sizes only allowed for me to recover from crashes every ~2-3 min. but did not stop it from happening. Full screen crashes lock entire system
Video card benchmarking/burn in software (furmark, etc) all rock solid, no issues with heat/voltage being too high that I could tell.
Only Diablo 3 game engine crashing display driver

Fix performed in order:
What I did that has so far fixed the issue *(disclaimer. I am leaning towards the AMD Overdrive causing the problem, I need to test more tonight to rule it out but it could just be a total sc!#*% and rebuild of single driver set)

Uninstall all C++ redistributables from Programs/features

Go to a you-tube video right click on it and turn off “hardware acceleration” for Flash. *(I don’t think this played a role in fixing it, but someone had mentioned it as a similar solution for SC2 crashes, if was still off when I resolved this so I left it)

Get Catalyst uninstaller
http://downloads.guru3d.com/download.php?det=1275
Ran Cat uninstaller, reboot, but into safe mode when it say to reboot

Driversweeper
http://www.guru3d.com/category/driversweeper/
Install & Run Driversweeper in safe-mode; search AMD/ATI, remove everything it finds
Reboot normal mode

Clear "ghost" video cards in device manager (if there I had previous 4600):
Show ghost devices in the Device Manager
Open a command prompt (cmd.exe) with administrator rights
Set the special environment variable with this command:
SET DEVMGR_SHOW_NONPRESENT_DEVICES=1
Start the Device Manager with this command: devmgmt.msc
In the Device Manager enable Show Hidden Devices in the View-menu
Uninstall any ghost video cards and their drivers
Reboot again

Download Catalyst 12.3
Install all Catalyst pack (I did custom just to be sure everything was checked off)
Reboot on finish – confirmed driver installed and environment stable with Furmark/GPuShark/GPU-z benchmark to check stability
**Left AMD overdrive off (no OC)
**Turned off MFAA
**Set everything that could be to “Use application settings

Start up D3 in windows mode (it’s how I had it running last)
Started playing in solo-mode, turned FPS all the way up to 200 – tested, no crashes so far
Turned all settings one by one to their max except:
Shadows (It’s a dark game, I leave it at blob or low or whatever)
I left physics on low to start
Kept playing, no crashes
Went to “full screen” mode – no crashes
Went back in, cranked all graphics settings to max, Vertical Sync is off. (It’s also off in CCC, and no triple buffering)
No crashes, seeing 89-100fps on my display at 1680x1050

I need to test public just to rule out that something to do with the public games is crashing it but so far it looks like this has fixed the issue for me. Hopefully it gives a few of you some help.

*updated - tested public game. no problems. 7750 with every setting now (even the shadows) maxed out at 1680x1050 with frame limited at 200, I'm seeing 55 low to 145 high FPS with no crashes!

Hope this helps some of you.
Reply Quote
Good work!
Reply Quote
Turned morph-AA back on with Edge detect in CCC. Everything ok so far. OC will be next to see if it stays solid.
Reply Quote
I have a radeon HD6770 and turned the factory clocking setting down from 900MHz to 800 MHz and am having no crashing so far. You can find this setting in the catalyst control center under Clocks.
Reply Quote
90 Draenei Shaman
13035
Not sure if this will fix my problem but I am having a similar issue and was hoping for a bit of input. Display driver randomly stops responding and windows recovers it. This is the only game that I have this problem with. Running a HD 6970 on Win7 SP 1. The complication tho is that I am not sure if I have Catalyst 12.3 or 12.4. The Vision control center says I have 12.3 and that there is an update for 12.4 available. I had it DL and install the update, restarted and still says I have 12.3. I manually DL'd and installed and same thing. However, when I check the driver version number under device manager, it lists the driver that is with 12.4. I'll try removing catalyst entirely and installing 12.4. Any other suggestions?
Edited by thatman#1713 on 5/19/2012 4:18 PM PDT
Reply Quote
The solution has worked for me. EVGA GTX260 SSC - factory overclocked, I have downclocked it using EVGA Precision X about 10%. Ingame settings: 1680x1050, everything on high, antyaliansing on. The game i nearly perfectly smooth right now.
Awaiting for a proper patch either from Blizzard or nVidia. Googling for a solution before, I found that a problem appeared also with other games (WoW, BFH) and seems to independent of graphic card or operating system.
Reply Quote
90 Draenei Shaman
13035
Followed the steps above and it did not work, driver still randomly stopped responding. I again tried to install Catalyst 12.4 and this time got an error "Driver Install: INF file not found" and it didn't install the driver. So I removed Catalyst again and tried to reinstall the 12.3. I got the same thing again. I had windows find a driver and it came up with version 8.850.0.0 which is way out of date (4/19/11). Now the Vision control center will not run either. Gonna put in a support request with them and see if they can sort this out as searching their knowledge base was fruitless.
Reply Quote
Kagero - With the INF file not found you need to do this

Go into device manager and right click the card because driver will not be installed.

Install it manually and point it to search for the driver in C/AMD or C/progrma files/ati or something.

Make sure you have search sub folders ticked as well.

It will find and install a driver for your card and then you can use the 12.4 and 12.3 catalyst installer again.
Reply Quote
The issue with this problem looks like it can be fixed by "undercocking" your graphics card slightly.

Nvidia has an easy tool to do this. Note sure about ATI.

Look at this forum for notebooks.

http://us.battle.net/d3/en/forum/topic/5151718530
Reply Quote
90 Draenei Shaman
13035
Go into device manager and right click the card because driver will not be installed.

Install it manually and point it to search for the driver in C/AMD or C/progrma files/ati or something.

Make sure you have search sub folders ticked as well.

It will find and install a driver for your card and then you can use the 12.4 and 12.3 catalyst installer again.


Did this and it installed driver version 8.961.0.0. Ran the 12.4 install and did not get the INF error. However it did not install a newer driver and now the control center will not run. It sits there in processes but doesn't do anything. When the install was complete it said there were issues but the install log did not list any errors or failures.

Also, my power plan was already balanced so no help there.
Edited by thatman#1713 on 5/20/2012 7:50 PM PDT
Reply Quote
Try again but make sure that there is no "broken" install when starting. Do this by running 12.4 again and selecting uninstall option. You might need to go through the processes in the first post again and then install driver manually again etc.
Edited by Hejeminey#6144 on 5/20/2012 8:03 PM PDT
Reply Quote
90 Draenei Shaman
13035
I did what you said and got CCC back. Going thru the settings again I found I had not turned Overdrive off. Could have swore I did but when everything started to go to hell it must have slipped my mind. That helped a great deal but did not fully get rid of the problem, the driver was still crashing but not nearly as much as before. I turned some of the game settings down and it seems to be working tho I have not had a lot of time to test. Will post again when I can test it more.
Reply Quote
limiting fps and underclocking my hd6950 seems to have fixed the problem.
Reply Quote
Any of this sound familiar...?

http://us.battle.net/d3/en/forum/topic/5149009547
Reply Quote
90 Draenei Shaman
13035
I fixed the problem for me. Turning settings down did not help. What did work was underclocking my gpu clock about 15%. Might not need to go that far but the game still runs smooth so I'll leave it. I was also getting the sporadic alt-tabbing bug so I checked CCC and it was showing more load on the card in some areas, esp. the dungeons in Act 1. So I also manually increased fan speed to keep the card cooler and that solved that problem. I played for a good 3 hours with no problems whatsoever. Hope this helps anyone else with this problem and thanks for your help everyone.
Edited by thatman#1713 on 5/22/2012 11:18 PM PDT
Reply Quote
This is pretty much my story as posted on another thread..

I can produce my amd driver is not responding on demand. I use a combination of OCCT to get the GPU really fired up, then I fast swtich to Trine 2 with full settings.. This causes a failure within minutes sometimes immediately and will repeat over and over until I lower the clock... (I had a crash in d3 thats what led me to start testing knowing that Trine 2 did it to me ALL the time.)

I down clock to 850 mhz (6870 900 is default) and I have yet to get Trine 2 to crash at this setting.. D3 only crashed ONCE ever on me, but as a hardcore player this is one too many, so I am very hopeful that stabilizing this issue with my method above does the trick.

The driver has stopped responding issue is pretty much a system stability issue plain and simple.. If it happens at the EXACT same spot everytime, this MIGHT be software /driver related, but for the most part, if your getting this problem (and yes I dont care if its ONLY d3) then your system / gpu is likely not 100% stable hardware wise..

I'm sure there are exceptions to this rule.. But with just about any hardware fault capable of causing this issue (PSU issues!) this is a toughie there is no doubt.. If a drastic downclock doesn't do it, your GPU just might be pooched.. Try another if you can..

So this leaves a serious question for graphics card manufacturers..
Reply Quote
90 Worgen Rogue
C N
5665
I have the same problem with my hd5850, this solution sounds really helpful rather than blizzard's online support. However, will this cause other problems, since you have deleted or reset something on you system, like decrease performance, display quality? If this will request you to sacrifice other quality of your system, it is really invaluable.
I am also playing wow and sc, and there are no this kind of issues. Diablo 3 is the only game that keep crash my display driver. So I have started to doubt what blizzard have in this ten years... I was so exciting when diablo3 was launching May 15, however, the errors and failures never stop to suck my game experience from the every begin, connection errors, server crash, display card driver recover.
My only wish is that no matter who, blizzard, nvidia, amd..., just somebody could update their production and fix this god damn problem.
Reply Quote
This shouldn't affect other other area's.. I found out some more about what's going on under the hood...

It's possible that people who have experienced more stability when choosing to disable use hardware acceleration in flash within their browser, is because for some reason when this option is CHECKED the video card ignores the clock limits set within the Catalyst Control Center.

For example.. I've been able to stabilize my card by slightly lowering the clock speed via CCC AMD over drive to 850mhz.. When running a youtube video, I noticed the clock going to 900 although I had set the limit to 850.. When I unchecked use hardware acceleration this behavior stopped and it will then stay at 850MHZ

I suppose it depends just how much you need to turn down the clock in order to get d3 stable.. But my clock automatically decreases to 100mhz when sitting at the desktop, so I doubt down-tuning will have any adverse affects (besides slight performance decrease of course).

I've opened a ticket with my graphics card manufacturer and I recommend all do the same who fall into my category.

Its starting to sound a little bit like these video cards are just not stable at their top rated clock speed. It doesn't seem to be heat related as I can get the card to the same failure point temperature even with a slight down-clock and it's fine.
Edited by Telerion#1585 on 5/24/2012 4:12 AM PDT
Reply Quote
Hey, guys-
My problem is that my driver stops responding(and gets recovered) ONLY when I view water like the oasis or canalisations in act 2. I got an Powercolor (ATI) Hd 6950 with a dual BIOS for 6970. I tried several drivers (11.11/ 12.3/ 12.4/ 12.4a) which didn´t work. Overheating is not causing this problems and in all other games I don´t get any problems. Additional the rest of D3 runs just perfect for my hardware level.
Reply Quote
90 Draenei Shaman
13035
05/24/2012 12:20 AMPosted by Wolfdz
I have the same problem with my hd5850, this solution sounds really helpful rather than blizzard's online support. However, will this cause other problems, since you have deleted or reset something on you system, like decrease performance, display quality? If this will request you to sacrifice other quality of your system, it is really invaluable.


I have not noticed any decreased performance after underclocking, the game still runs fine. If you are concerned about other games, just turn it back off. When I play D3 I go into CCC and enable my underclock settings and when I'm done I turn them off since this problem only happens in D3.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]