Diablo® III

120hz monitor vsync locks at 60 fps

BUMP - come on Blizzard, at least acknowledge this problem!
Reply Quote
I'll throw my hat in too. I'd like to be able to play at 120 vsync as well.
Reply Quote
Sorry guys but development time constraints just weren't long enough to add 120hz support, that would have required at least another year.
Reply Quote
I have the same problem.

I bought a 120Hz Monitor mainly for D3 and now it bugs around.
The other Problem ist, that even when i turn on vsync in game and play at 60Hz it is more laggy than other games at 60Hz.

When i turn off vsync the game goes totally crazy.
It looks like the game changes fps every frame between 60 and 100+ and jitters like hell.

And thats without SLI/Crossfire. I run a HD6870, C2D E8400, 4GB RAM.
Edit: Monitor is a Benq XL2420T over DualLink-DVI.
Edited by MaxPower#2867 on 5/31/2012 1:45 PM PDT
Reply Quote
Bumping this again to have it added to the bug list

Please let us know if you need some sort of proof surrounding this problem
Reply Quote
Bumping this again to have it added to the bug list

Please let us know if you need some sort of proof surrounding this problem


what exactly do you think "bumping" will accomplish...the people who monitor these thread don't see them in the same order...every post is read, and now they have to read your "bumps"
Reply Quote
yep, vsync is vsync.
vsync is not "lock framerate to 60 fps regardless of monitors capabilities"

i would really appreciate proper vsync , or proper framelocking.
if i for instance lock the framerate to 120, it stays at around 114.
if i lock it at around 125, it sits around 119.3.

both these issues ( vsync and accurate framelock ) should be addressed.
Edited by Devildoll#2517 on 5/31/2012 5:36 PM PDT
Reply Quote
nothin in this patch either
Reply Quote
an alternative for radeon users is to use a third party program called radeonpro.

ive forced vsync there @ 120 fps, and shut the ingame vsync off. now i'm pretty locked to 120.
Reply Quote
Its pretty weird what's happening here, with vsync enabled, everything says enabled (in my case) it should cap at 85fps, but caps at 60fps.

These are my settings:
VSync On in Diablo III Settings
Max Foreground FPS is off
DisplayModeRefreshRate "85" (from D3Prefs.txt inside "My Docs/Diablo III")
Monitor OSD says its running on 1600x1200 @ 85Hz
Using Nvidia Drivers 301.42
Have a GTX 580 SLI setup.

So its pretty weird that I see no tearing while the display is at 85Hz, but have 60fps.

Here's what I've tried:
Force VSync On for Diablo III in Nvidia Drivers (also tried Adaptive VSync, still caps at 60fps)
Fullscreen and Fullscreen Windowed
Edited by Quzzap#2184 on 6/1/2012 6:11 AM PDT
Reply Quote
updated to beta drivers tried new crossfire profiles still no change
Reply Quote
Bumping too : wouldn't cost much to patch VSync so that it detects the monitor's frequency.
Right now, dealing with it by putting a 140 max FPS foreground (~120 actual FPS).
Edited by RollingPanda#2953 on 6/3/2012 2:49 PM PDT
Reply Quote
Ok new patch time maybe something will change just enough to make my vsync work properly

Fix fps smoothing please something is wrong with it!!!!
Reply Quote
still same :(
Reply Quote
an interesting read if anyone wonder what vsync does/how it work.

http://hardforum.com/showthread.php?t=928593
Reply Quote
I disabled the in game vsync and enabled it threw nvidia control panel, worked for me 120 fps @ 120hz....
Edited by JogOn#2235 on 6/14/2012 12:00 AM PDT
Reply Quote
120hz works inall the other games I play, even games from small indie teams. Certainly a massive dev team like Bliz can make it work.
Reply Quote
Another 120hz'er here. And yep, D3 does not support non-60hz refresh rates as well is it should. Would love to properly see this running at 120fps in 120hz.

The difference between 60 and 120 is truly day and night, and once you do so much as drag a window across your screen at 120hz you will never want to go 60hz again.
Reply Quote
make sure windows monitor refresh rate is set to 120hz
if it is 60, then vsync is working properly


Right-click the windows desktop, and then click Personalize.
Click Display.
Click Change display settings.
Click Advanced settings.
Click the Monitor tab and change Screen refresh rate to 120 Hertz.
Click Ok.
Reply Quote
With 60hz and V-sync on, FPS are fixed at 60 max. No matter what you do.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]