Diablo® III

120hz monitor vsync locks at 60 fps

First of all - "refresh rate" has nothing to do with LCD monitor, that's hilarious or stupid, cant really decide to laugh or cry here.

Second - your pc cant handle STABLE 120 fps, so you get 60, this is how vsync works sadly - if your pc cant handle refresh rate setting, your frames are halved and nothing can fix that, besides upgrading your pc or reducing graphic settings, to get STABLE 120+ fps.
Reply Quote
Posts: 2,907
First of all - "refresh rate" has nothing to do with LCD monitor, that's hilarious or stupid, cant really decide to laugh or cry here.

Second - your pc cant handle STABLE 120 fps, so you get 60, this is how vsync works sadly - if your pc cant handle refresh rate setting, your frames are halved and nothing can fix that, besides upgrading your pc or reducing graphic settings, to get STABLE 120+ fps.


What the hell are you talking about?

I was able to run the beta at 120hz in Vsync no problem. The game ran butter smooth then. Now it locks to 60 no matter what I do. This has also caused 3D Vision to not function properly anymore either as i don't get 60hz per eye.

This needs a fix.
Reply Quote
Bump this. Blues?
Reply Quote
06/21/2012 12:38 AMPosted by Alcovitch
Now it locks to 60 no matter what I do.

Try the following:
a) disable in-game frame limiter and vsync;
b) disable vsync and triple buffering forcing through any other third party utility or GPU driver control panel;
c) use FRAPs to measure achived FPS;

Execute the game and monitor non-vsync FPS you'd get. In case it's extremely jerky (changes rapidly by 2x/3x) - try limiting CPU affinity of the main game process to use only one or two CPU cores (google for it if you don't know how to do it). Net result should be reasonably stable FPS (in case you don't move your character). Check the numbers you get. In case they would be lower than 120FPS - you would have vsync locking FPS to 60 as soon as you turn it on.

As far as I know D3 seems to be extremely CPU bound game that is not optimized to make use of multicore CPUs, resulting in typical FPS numbers limited to ~70-110 range for most in-game locations due to CPU not being able to perform better. IMO that's the main problem with D3 and that really should be fixed as it's not OK for 2012 game to be essentially single-threaded and CPU bound.
Reply Quote
i got the same issue, with almost exactly the same system ( one 6870 no ssd)

there is still micro stuttering when i enable vsync and it seems to constantly jump from 59to60 and back. frame limitter doesnt work. if i set it to 60 it limits at 50 wtf?

they game jsut runs really bad on my pc although i shouldnt have any problems with my system specs

well hope this will get fixed but i dont think so. already had these problems in beta
Reply Quote
if you have vsync on, disable the foreground frame limiter
if the frame limiter is shorting the gpu slightly, it will not get to the 60 that vsync needs
Reply Quote
Posts: 71
Bump, I have a 120hz monitor and am capped at 60hz.
Vsync should set the refresh rate at 120hz since that is my desktop refresh rate not 60hz.
Reply Quote
Posts: 1,092
View profile
bump! i have a new 120hz monitor and am noticing the same exact thing. Blizzard, please implement this for us!
Reply Quote
First of all - "refresh rate" has nothing to do with LCD monitor, that's hilarious or stupid, cant really decide to laugh or cry here.

Second - your pc cant handle STABLE 120 fps, so you get 60, this is how vsync works sadly - if your pc cant handle refresh rate setting, your frames are halved and nothing can fix that, besides upgrading your pc or reducing graphic settings, to get STABLE 120+ fps.


Wow. You actually have zero clue what you are talking about. You don't know what a 120hz monitor is and you definitely don't understand what vsync is or does, especially on a 120hz monitor. Go read and come back when you have educated yourself.

Anyhow, I too have seen this happen. I fired the game up and first thing I notice is that I'm locked at 60. It definitely wasn't like this before.
Reply Quote
Posts: 1,092
View profile
bump! Blizzard please address this issue!
Reply Quote
got the same problem but now got it to work with 120Hz

1. vsync Diablo OFF and Max FPS to Max

2. nvidia inspector: preferred refresh rate to:
REFRESH_RATE_OVERRIDE_HIGHEST_AVAILABLE

3. nvidia inspector: vertical sync: Force ON

4. nvidia inspector: Frame Rate Limiter to 120fps
Reply Quote
I am having the same issue. Getting upward of 200 fps with V-sync disabled yet it locks me at 60 fps with V-sync enabled. Running the Asus VG278H with an Nvidia GTX 660ti, the MSI Power Edition. It works at 120Hz/120fps in other games with V-sync enabled @ 1080p, just not D3. I get a steady 60fps with 3D Vision enabled.

I'm going to try what B34tnU posted and will reply if it works.

Still would love to hear from Blizzard about this though. There are enough of us with 120Hz monitors to warrant a response.
Edited by Blankie#1190 on 3/2/2013 9:17 PM PST
Reply Quote
What B34tnU posted does work for me. I am successfully achieving 120fps with Nvidia Control Panel managing the V-Sync. Thanks for the tip, never thought to force it that way.
Reply Quote
I did something similar to B34tnU, but using nvidiaInspector.
Basically I disable the ingame vsync and force it through the drivers.

So I fire up diablo 3 and voila 120fps at 120Hz... except... THE GAME IS NOT RENDERING MORE THAN 60 FPS.
Wait... that's a lie, the mouse is updated 120 times... but not everything else.

Ok... how can I tell that the game is not rendering 120fps?
Well, I have an Asus VG278H, a 120Hz monitor that has nvidia Lightboost 2 support. The nifty lightboost can be forced to run in 2D at 120Hz instead of its original purpose for 3D at 60Hz.

Lightboost basically make the LCD monitor behave like a CRT.
So how does diablo 3 look on a 120fps/120Hz 'CRT'?
Everything is doubled when moving. The faster the object moves, the further away its double is.
So if you look at a character in the background or an item label on the ground it looks normal when standing still, but it gets doubled when you start moving.

Now what does that double image mean? It means you're only getting 60fps.
Apparently that's how our eyes perceive movement when the same frame is repeated twice.

So on a CRT:
60fps at 60Hz -> smooth
60fps at 120Hz -> double image
40fps at 120Hz -> triple image! (tested with fraps)

Note: To make sure my monitor isn't to blame I also tested diablo 3 on an old 85Hz monitor. I made the game run at 85fps... and sure enough, the image was not smooth. I think it was a jittery double image effect.

Since diablo 3 looks rather silly on a 120Hz 'CRT', I now play the game with ingame vsync set to on, refresh rate to 120Hz and lightboost off. I find the LCD hold and sample blur to be less disturbing than having double images.

Now for some proof for those who don't have a CRT or a lightboost 2 LCD.
I lowered everything I could to be able to fraps the game at 120fps.
I more or less succeeded, check this video out, you should notice the game only updating every other frame (except the mouse!)
https://www.box.com/s/vymgtf84z2zununf287c

So I don't know. My assumption is that the game never renders more than 60fps... even with vsync off. (I get the double image effect at 140fps as well, just more jittery)
There's a possibility my drivers or hardware (660ti) are to blame, but I doubt it. (titan quest and torchlight both look pristine at 120fps, and I've seen the double image effect on other games that are capped at 60fps regardless of monitor refresh rate - Bit Trip Bit, Bit Trip Runner)

The funny part is... the game looks just fine in 3D (no blur, no double images). Too bad it is unplayable that way, the item labels have no depth...

Who knows, maybe the game will be patched in future.
Reply Quote
100 Human Warrior
12945
Posts: 12
Bumping this to confirm what Ansive has said. Can we get a post or link on this?
Reply Quote
My situation is similar with Ansive.
I set V-sync off in game, and set V-sync on by NVIDIA Control Panel. I took video of my game screen by Dxtory, then I found out that the mouse cursor was rendered in 120fps, but the other part of the screen is rendered in 60fps.
Reply Quote
Bump. still not fixed. Vsync does not match screen refresh rate. 120hz and 144hz. also Max Foreground FPS is still way off./ currently set to 153fps and shows 143fps.
Reply Quote
Posts: 471
Got a new monitor, suffering the same issue now.

Patch 2.0 did not change anything.

This is unacceptable.
Reply Quote
Plaese Blizzard make an update and fix this Problem !
Reply Quote
05/27/2012 08:28 AMPosted by Fëanor
What's the problem with 60fps? I really don't think you can see much difference between 60 and 120. 60 and 30, yeah, it's night and day, but 60 and 120? No, definitely not.

I assume the game caps the framerate at 60 for some reason or another.


This guy has your answer...the human eye cannot perceive anything over 60fps and 23 is video quality. All your 120 is going to do is enable 3d or dual view if you are running/using anything that even supports either.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]