Diablo® III

How I Fixed Diablo 3 FPS Slowdowns

i have about everything set to high and my fps's like in the middle and i don't really get that much lag..my graphics are kinda dull though andy have the top of the line mac software
Reply Quote
This fixed my issue. I disabled trilinear filtering and turned off shadows. I had the problem where the game would run find for 5-20 mins then slow down to a very low frame rate. Rebooting was the only way to recover. I have a mid 2010 MBP with the NVIDIA GeForce GT 330M 512MB.
Reply Quote
Did not work for me. Still getting 10-15 fps.
Reply Quote
Just tried this on my 9400M MBP. Zero difference. Don't bother.
Reply Quote
90 Undead Warrior
13055
Posts: 32
This had no effect for me, however I've only experienced issues in Dahlgur Oasis, my fps will drop from 24 (where I have capped it) to around 10-12.

MB Pro 5,3, Core 2 2.8 GHz, 8 GB Ram, 512 MB 9600M GT, 22" 1080p external monitor.

Game settings: Full Screen 1280x720 (why yes, my UI IS blurry as hell), Letterbox: off, V Sync: off, Max FPS Fore/Back: 24/8, Texture: Low, Shadows: Off, Physics: Low, Clutter Density: Off, AA: Off, Low FX: On

I have not experienced any slow down after hours of play, only that one zone tanks my fps. I'm going to blame the dense foliage and heavy fog in the area. Maybe exercise a little restraint in the future environment artists, who aren't reading this.
Reply Quote
This had no effect for me, however I've only experienced issues in Dahlgur Oasis, my fps will drop from 24 (where I have capped it) to around 10-12.

MB Pro 5,3, Core 2 2.8 GHz, 8 GB Ram, 512 MB 9600M GT, 22" 1080p external monitor.

Game settings: Full Screen 1280x720 (why yes, my UI IS blurry as hell), Letterbox: off, V Sync: off, Max FPS Fore/Back: 24/8, Texture: Low, Shadows: Off, Physics: Low, Clutter Density: Off, AA: Off, Low FX: On

I have not experienced any slow down after hours of play, only that one zone tanks my fps. I'm going to blame the dense foliage and heavy fog in the area. Maybe exercise a little restraint in the future environment artists, who aren't reading this.

This^

Dahlgur Oasis is terrible. Everywhere else is playable for me. (Playable being ~20fps).
Reply Quote
Posts: 22
05/18/2012 08:29 AMPosted by Liekhan
This fixed my issue. I disabled trilinear filtering and turned off shadows. I had the problem where the game would run find for 5-20 mins then slow down to a very low frame rate. Rebooting was the only way to recover. I have a mid 2010 MBP with the NVIDIA GeForce GT 330M 512MB.


Glad it helped :) I have the exact video card too.. Its not perfect but is playable at least.
Reply Quote
Hey, i have trouble finding DisableTrilinearFiltering "0".... what is it close to in text edit when i've opened d3debug.txt? I really need some help here, can't stand lagging this bad...
Reply Quote
hey i got a standard macbook pro, whatever graphics card it came with is what im using. at 20 fps the game seems to be running fine but i wouldnt know what to compare it to cause ive never seen it above 20. usually its between 5-15 and its impossible to play. yes i did all the troubleshooting and have all the preferences set to maximize performance but nothing helps.

I did the textedit DisableTri to 1 and that didnt make any difference for me
Reply Quote
Okay, i see now that I can't find the folder your telling me to find. I search for Blizzard, but has no such thing in my computer. If there is someone who can make a video on youtube of this, or show pictures on some forums, step to step, it could be really nice, thanks!

-Princip
Reply Quote
I found the right file now, but when i make the search thing in the document, it won't find what you tell me to change to "1"...

were about is it in the document? top, mid, bottom?
Reply Quote
This is how i fixed it (average 40 FPS now)

My specs:
MacBook Pro Mid 2010
2,5 GHz Intel Core i5
8 GB RAM
NVIDIA GeForce GT 330M
Mac OS Lion 10.7.4

as i first tried to manually install the nvidia beta driver,
which caused not beeing able to boot my system any more,
i had to reinstall to get the original drivers back...

all system preferences are configured
like mentioned in several posts in this forum

Then i deleted all unnecessary apps from startup
and now i just run these apps:
gFxCardStatus (manually switch between integrated cards)
smcFanControl (manually adjust fan speed)
Sleepless (definitely prevent sleep mode)

as i allready know, that if i start chrome
it switches to discrete card (if switching allowed),
i start it with just one empty tab (no waste of ressources),
although i configured gfxcardstatus to only use the discrete one
smcFanControl is set to maximum fan speed so it doesn't change during playing
sleeples is set to prevent sleep mode which is the only possibility
to absolutely prevent any kind of sleep mode

all settings are set to low / off
trilinear filtering is still on (may try this next time for further improvement)
resolution is 1280 * 800
max FPS 50
BG FPS 1

and... tadaaaaaaa - average 40 FPS
in some areas it drops to 25 for a few moments
but mainly absolutely playable!

will try the trilinear option tomorrow,
and maybe set all settings except shadows back to default

if anyone gets similar results, please let me know :)
Reply Quote
helped. thank you
Reply Quote
I don't see what you did to get better fps? other than do normal low settings in game? did you download any software which helps the fps? i really need some help with this, I'm tired of not being able to play in subtend maps cause of lagg issues.
Reply Quote
Then i deleted all unnecessary apps from startup
and now i just run these apps:
gFxCardStatus (manually switch between integrated cards)
smcFanControl (manually adjust fan speed)
Sleepless (definitely prevent sleep mode)


as i allready know, that if i start chrome
it switches to discrete card (if switching allowed),
i start it with just one empty tab (no waste of ressources),
although i configured gfxcardstatus to only use the discrete one
smcFanControl is set to maximum fan speed so it doesn't change during playing
sleeples is set to prevent sleep mode which is the only possibility
to absolutely prevent any kind of sleep mode
Reply Quote
85 Tauren Druid
8610
Posts: 285
To repeat (should be in the the thread title), these steps will NOT help 9400M chip users. The people who are saying it helped them have the 330M

So if you have the 330M Graphics Chip, then sure..try it out and see it if it helps you.

If you have the 9400M, it is not going to make any difference for you.
Reply Quote
im on a mac and i didnt have this problem to start, but my friend is on a mac and has had really bad lag. This fixed it for him! You deserve a medal bro.
Reply Quote
85 Draenei Shaman
0
Posts: 48
THANK YOU.

This worked for me. I think this will be able to sustain me until Blizz actually fixes it.

Note: It still lags every now and then but only during really intense encounters (lots of stuff on screen).

Using a 15-inch MBP 2011 model.

Cheers mate!


This is going way to extreme for 2011 model. For this model you might just want to disable max foreground FPS and set highest resolution with VSYNC On. Rest of the settings should be default. The above method is more for 2009 and below machines.


I have been getting 37-45 FPS by choice with the following settings on my Early 2011 i7 2.2GHz MBP 15 inch (1680x1050), 16GB RAM, SSD, 10.7.4, 1GB ATI. Copying OP's nice chart:

In Diablo 3
I set my display to full screen
resolution to 1680x1050 (or whatever your native resolution is)
UN-Check - Vertical Sync
Check - Max Forground FPS and set to 150
Check - Max Background and set to 8
Set Texture Quality to High
Set Shadow Quality to OFF
Set Physics to HIGH
Set Clutter Density to HIGH
Make sure Anti-Aliasing is ON
UN-Check Low Fx

I can play for hours, no slow downs. If I lower res (1280x720), I can get FPS to over 60FPS with same settings above. For every level of Shadow Quality I go, I lose about 10FPS.
Reply Quote
Posts: 22
tried the .txt edit with my 2008 aluminum macbook (9400m only). no difference.
Reply Quote
05/18/2012 08:29 AMPosted by Liekhan
This fixed my issue. I disabled trilinear filtering and turned off shadows. I had the problem where the game would run find for 5-20 mins then slow down to a very low frame rate. Rebooting was the only way to recover. I have a mid 2010 MBP with the NVIDIA GeForce GT 330M 512MB.


I have the exact same mac as you and that will work for awhile and then it'll still happen. It's completely random though a lot of creatures on the screen at once seems to trigger it. Happens in Co-op too.
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)

Reported!

[Close]