Diablo® III

How I Fixed Diablo 3 FPS Slowdowns

Just wanted to say that I have a 3-year-old 17" MBP with an nVidea 9600M GT (512 MB GDDR3). I've put in over 30 hours now on Diablo III and, despite not playing with the 9400M, I too was experiencing extremely poor frame rates. What was interesting was that it didn't happen immediately. I could play for hours just above 20 fps and then it would drop below 10 fps and wouldn't recover. That was with physics and textures set to high.

Model Name: MacBook Pro
Model Identifier: MacBookPro5,2
Processor Name: Intel Core 2 Duo
Processor Speed: 3.06 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache: 6 MB
Memory: 8 GB
Bus Speed: 1.07 GHz
Boot ROM Version: MBP52.008E.B05
SMC Version (system): 1.42f4



NVIDIA GeForce 9600M GT:

Chipset Model: NVIDIA GeForce 9600M GT
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0647
Revision ID: 0x00a1
ROM Revision: 3436
gMux Version: 1.7.10
Displays:
Color LCD:
Resolution: 1920 x 1200
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes



System Software Overview:

System Version: Mac OS X 10.7.4 (11E53)
Kernel Version: Darwin 11.4.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Computer Name: EinMacBookPro
User Name: Eingang (eingang)
Secure Virtual Memory: Enabled
64-bit Kernel and Extensions: Yes
Time since boot: 38 minutes


What I've discovered is that I can usually acceptably play by doing the following things:


  • Playing in native 1920x1200 resolution.
  • Physics set to high.
  • Textures set to high.
  • Clutter set to off.
  • Shadows set to off.
  • Low FX enabled.
  • Antialiasing disabled.
  • Editing the Diablo3 prefs file as described to set DisableTrilinearFiltering to "1".
  • Set maximum FPS in the foreground to about 40.


Then, and this seems to be the most important, restart the laptop before starting to play.

After doing that, it's consistently playable for 6 or more hours on end. I don't mean I get 30 fps all the time (sometimes) but it's usually at least 20ish and it doesn't consistently drop and stay below 15 fps.

Your mileage may vary. Good luck.
Reply Quote
I did the following and it seemed to work. I have 9400M:
1- All graphics settings on low. Note: Game looks OK, not great.
2- graphics set for performance and not battery. System Settings>Power Saver
3- In the game options, set background FPS to 1 and Foreground FPS to 50.
4- I am playing at 800x600 resolution.

Gameply is fine, not choppy. Graphics don't look awesome but to be honest, I am not playing for graphics detail. I am playing for gameplay and lore and loot pinatas. Hope others have success with this.
Reply Quote
it works! thx!!!!
Reply Quote
Posts: 287
what about the 8600 m gt
Reply Quote
I wonder if there was a way to disable the graphical globes for your health and MP(class) globes and just make it a plain color. It seems that the water running or mist seems to behave quite the same as the mist in the globes so when there are three to four of these types of graphics on the screen at once it might slow the computer down (even really fast computers) since it seems like a lot of background motion. If anyone finds a way to disable the globe graphical effects let me know ....
Reply Quote
.
Edited by Loony#1587 on 5/21/2012 7:05 AM PDT
Reply Quote
None of this worked for me for the 330M.
Reply Quote
Like many other Mac users, after 4-5 mins of gameplay, the game would slow down to a crawl. Looking at the forums, I saw I was not the only ones with the same problem. I ended up fixing the problem myself by doing numerous things both Inside and Outside of Diablo.

In Diablo 3
I set my display to full screen
resolution to 960x600 (or whatever your native resolution is)
Check - Vertical Sync
Check - Max Forground FPS and set to 50
Check - Max Background and set to 1
Set Texture Quality to Low
Set Shadow Quality to off
Set Physics to Low
Set Clutter Density to Off
Make sure Anti-Aliasing is OFF
Check Low Fx

Exit the game and now do into System Preferences in Mac OSX
Go to Energy Saver and make sure Automatic graphics swithing is unchecked!

Now its time to edit the config file for Diablo III
You will have to edit a diablo preference file in
/Users/<<<Your User name goes here>>>/Library/Application Support/Blizzard/Diablo III/D3Prefs.txt

To get there the EZ way (because its a hidden file)

Click on the background of your desktop to make sure you in the "Finder Menu"
- Hold Down the Option Key and hit GO, then click Library (should show up under home)
- Open the Application Support Folder
- Open the Blizzard Folder
- Open The Diablo III Folder
- You will see a file called D3Prefs.txt open that with your text editor
- You will see a line that says DisableTrilinearFiltering "0" change this to DisableTrilinearFiltering "1"
- save file!

My Specs are 2.66 Intel Core i7 Macbook Pro, 8 GB Ram, NVIDIA GeForce GT 330M 512 MB, OSX Lion.

I Hope this helps everyone in the mean time until we get a patch to fix this issue!


Thank you and I'd also like to add a discovery that I found last night: Laptop heating causes FPS problems.

I have a late 2008 MBP 15", 8 GB RAM, Nvidia 9600 512 mb and OSX lion.

I removed the battery from the laptop and I have a laptop cooling pad with a fan. SMC fan control is around 160-170F with 6000 RPM setting. My FPS improved, I'm running at 20-30 average and it's not choppy.

When I have the battery in the laptop and had no laptop cooling pad, my temperature is around 200F = not good (Choppy FPS). The first 5 minutes are good then it all goes downhill. It plays at around 5-10 FPS.

Hope this helps some of you out there.
Edited by ELLV8#1660 on 5/21/2012 2:49 PM PDT
Reply Quote
Life saver

Worked on my iMac 24in
Reply Quote
Posts: 287
does it work for 8600 m gt?
Reply Quote
I did this and it didnt change anything. Then 1 day later i had super smooth great gameplay for roughly 20 minutes. Then my mac crashed, restarted, and im playing a slideshow again
Reply Quote
iMac 7,1. 2.4 g core 2 duo
4g ram
Ati 2600 HD
OS 10.6.8

After install repaired permissions, made this change set max frames to 45 and that's pretty much what I get outside of a complete screen of monsters.
Also note that if you edit your video prefs in game it sets this back to "0".
The manual edit needs to be done last, outside of game and saved.
* disclaimer: I did not read back through to see if anyone already pointed out that last part. Forgive any redundancy.
Reply Quote
05/21/2012 04:14 PMPosted by OscatroN
does it work for 8600 m gt?


I am running the minimum system for the game with the 8600. I was getting 15-20 fps and went through the steps recommended by the OP. Now I am running 23-30 consistently for the last couple hours. Seems to have helped some for me.
Reply Quote
Posts: 8
Anybody with the 330M have success with this?

What's weird about this issue is that, at least for my MBP, I was able to play without any issues from launch day until yesterday. Then all of the sudden the slowdown started happening, and it wasn't just in D3 - I would switch to Chrome or Mail.app and have the same slowness.

Strangely enough, when I checked Activity Monitor and top for any hints as to what may be going on, D3 (or any other process) did not seem to be using an abnormal amount of CPU or memory.

Was there some kind of patch or update that was pushed to our clients automatically?

my specs for the record - 2.66 GHz i7, 8GB RAM, OS X 10.7.4, nvidia gt 330M
Reply Quote
Face reality. Macs are equipped with very weak hardware for the pricetag they carry. With the cards you are posting around you cannot expect to reach fluent fps even once the timed slowdowns are sorted out. Who has 8 fps in a battle now will have 8 fps in a battle later, it's simply a subpar VGA that is your issue.
Edited by mystrdat#2106 on 5/23/2012 7:26 AM PDT
Reply Quote
Posts: 59
05/23/2012 07:26 AMPosted by mystrdat
Face reality. Macs are equipped with very weak hardware for the pricetag they carry. With the cards you are posting around you cannot expect to reach fluent fps even once the timed slowdowns are sorted out. Who has 8 fps in a battle now will have 8 fps in a battle later, it's simply a subpar VGA that is your issue.

It's wonderful that you know so much about Macs and their graphics cards... I mean, it couldn't possibly be an issue with graphics drivers like it has been in the past with every single Blizzard release since vanilla WoW... nah.

Get a Mac or get out of the Mac forum.
Reply Quote
90 Pandaren Mage
7115
Posts: 30
If all else fails run on Bootcamp and juice up your fans to keep the GPU cooled. A few minor tweaks to Foreground FPS = 40 and Vertical Sync On should do the job even with a really old Macbook Pro. Mine is a Late 2008.
Reply Quote
MBP i7 2.66Ghz, 8GB Ram, GT330M
tried the trilinear thing, no difference.
if I reboot I can play normally, sometimes for hours, but normally for about 30 mins, then it slows to a crawl.
ridiculous, had no such problems with the beta
Reply Quote

Please report any Code of Conduct violations, including:

Threats of violence. We take these seriously and will alert the proper authorities.

Posts containing personal information about other players. This includes physical addresses, e-mail addresses, phone numbers, and inappropriate photos and/or videos.

Harassing or discriminatory language. This will not be tolerated.

Forums Code of Conduct

Report Post # written by

Reason
Explain (256 characters max)
Submit Cancel

Reported!

[Close]